camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregor Zurowski (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-7285) Upgrade Apache Jackrabbit Library for camel-jcr Component
Date Mon, 17 Mar 2014 18:17:45 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-7285?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gregor Zurowski updated CAMEL-7285:
-----------------------------------

    Attachment: MANIFEST.MF

All current Jackrabbit releases are OSGi-ready. See the attached MANIFEST file of the jackrabbit-jcr-commons
JAR that is used by Karaf's camel-jcr feature: I has all the required OSGi manifest headers
such as Export-Package and Bundle-Version.

{code}
[...]
Export-Package: org.apache.jackrabbit.commons;uses:="javax.jcr,javax.j
 cr.version,javax.jcr.nodetype,javax.jcr.lock,org.apache.jackrabbit.co
[...]
Bundle-Version: 2.6.5
[...]
{code}

> Upgrade Apache Jackrabbit Library for camel-jcr Component
> ---------------------------------------------------------
>
>                 Key: CAMEL-7285
>                 URL: https://issues.apache.org/jira/browse/CAMEL-7285
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-jcr
>            Reporter: Gregor Zurowski
>            Assignee: Gregor Zurowski
>            Priority: Minor
>             Fix For: 2.14.0
>
>         Attachments: MANIFEST.MF
>
>
> Upgrade the Apache Jackrabbit library for the camel-jcr component to the latest stable
release (2.6.5). Currently Camel still uses the older 2.2.12 version of Jackrabbit.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message