camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aki Yoshida (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-7020) Make camel servlet related components deployable on OSGi with servlet 3.0
Date Wed, 27 Nov 2013 13:03:35 GMT
Aki Yoshida created CAMEL-7020:
----------------------------------

             Summary: Make camel servlet related components deployable on OSGi with servlet
3.0
                 Key: CAMEL-7020
                 URL: https://issues.apache.org/jira/browse/CAMEL-7020
             Project: Camel
          Issue Type: Improvement
          Components: camel-cometd, camel-gae, camel-http, camel-http4, camel-servlet
    Affects Versions: 2.12.2
            Reporter: Aki Yoshida
            Assignee: Aki Yoshida


Currently, those camel components that depend on javax.servlet do not explicitly specify the
version range in their corresponding pom. As a result, the import range is automatically generated
in the manifest with "[2.6,3)" which excludes version 3.0.

This patch will add the version range in those relevant pom files so that version 3.0 is also
accepted.

Reference
http://camel.465427.n5.nabble.com/import-version-range-for-javax-servlet-in-camel-servlet-et-al-td5743849.html



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message