camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Babak Vahdat (JIRA)" <>
Subject [jira] [Created] (CAMEL-6985) Clean-up the codebase of the Karaf commands a bit
Date Wed, 20 Nov 2013 01:42:18 GMT
Babak Vahdat created CAMEL-6985:

             Summary: Clean-up the codebase of the Karaf commands a bit
                 Key: CAMEL-6985
             Project: Camel
          Issue Type: Task
          Components: karaf
    Affects Versions: 2.12.1
            Reporter: Babak Vahdat
            Assignee: Babak Vahdat
            Priority: Minor
             Fix For: 2.13.0

- Better avoid the current code duplication for the {{camelController}} field and it's corresponding
setter  by different commands & completers and extract it out into the {{CamelCommand}}
& {{CamelCompleter}} abstract base classes.

- As a general rule of thumb always iterate over {{Properties#entrySet()}} instead of {{Properties#keySet()}}
which is faster as you skip the lookup step inside the given {{Map}}/{{Hashtable}} by each
iteration inside the loop.

- After CAMEL-6980 remove the {{CamelController#getRouteDefinitions()}} API and it's implementation
by {{CamelControllerImpl}} as there's no usage of it anymore.

- Correct the text alignment of the "Properties" information given by the "route-info" command,
that's the {{RouteInfo}} class.

This message was sent by Atlassian JIRA

View raw message