camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CAMEL-6240) Http4 component does not support PATCH
Date Mon, 30 Sep 2013 21:18:24 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-6240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13782251#comment-13782251
] 

Christian Müller commented on CAMEL-6240:
-----------------------------------------

I couldn't find any reported security issues with HTTP PATCH. Because nobody added a valid
comment why we shouldn't support it in the last 6 month, I will go ahead and check the patch...

> Http4 component does not support PATCH
> --------------------------------------
>
>                 Key: CAMEL-6240
>                 URL: https://issues.apache.org/jira/browse/CAMEL-6240
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-http
>    Affects Versions: 2.10.4
>            Reporter: Jason Chaffee
>            Priority: Minor
>         Attachments: http4-pathmethod.patch
>
>
> If I try to use PATCH, it gives me an error about it not being in an enum.  However,
the HttpClient does support it.
> http://hc.apache.org/httpcomponents-client-ga/httpclient/apidocs/org/apache/http/client/methods/HttpPatch.html



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message