camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Alkemade (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-6223) NullPointerException on startup in WebSphere 7.0.0.27
Date Tue, 02 Apr 2013 15:23:17 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-6223?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13619921#comment-13619921
] 

Tim Alkemade commented on CAMEL-6223:
-------------------------------------

We are in the process of contacting them. But since I saw several similar stacktraces during
my google searches, which seemed to be solved in some cases by a fix in camel, I thought it
might be worth investigating if this is a similar issue. 
                
> NullPointerException on startup in WebSphere 7.0.0.27
> -----------------------------------------------------
>
>                 Key: CAMEL-6223
>                 URL: https://issues.apache.org/jira/browse/CAMEL-6223
>             Project: Camel
>          Issue Type: Bug
>    Affects Versions: 2.6.0, 2.10.3, 2.10.4
>         Environment: Webshpere 7.0.0.27
>            Reporter: Tim Alkemade
>         Attachments: camelnullpointer (1).zip, stack.txt
>
>
> On WebSphere 7 with service pack 7.0.0.27. When starting up a web application, I get
the NullPointerException in the attached the stacktrace inconsistently. About half the time
it fails, half the time it succeeds. I played around with adding and removing different versions
of jaxb (2.1.10. 2.2.5, 2.2.6) , parent first / last classloading and different versions of
Camel (2.6.0, 2.10.3, 2.10.4) , but none of these actions worked. 
> To be clear, it only fails on this specific version of WebSphere. On the 7.0.0.23 version
of websphere, tomcat, jboss and jetty the application runs. 
> I created a minimal maven project which will produce a war file that reproduces the error.
> I posted this issue on the forums, but got no response: http://camel.465427.n5.nabble.com/NullPointerException-with-Camel-WebSphere-7-td5729625.html

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message