camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josep Boix Requesens (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-4209) Upgrade camel-guice to use guice 3.0
Date Thu, 20 Dec 2012 12:37:14 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-4209?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Josep Boix Requesens updated CAMEL-4209:
----------------------------------------

    Attachment: camel_guice_3.0.diff

Here is a patch I've created that uses guice 3.0 and removes guiceyfruit dependency.

I've basically isolated the code from guiceyfruti to preserve the JSR 250 compliant module.
Let me know if there is any further problem so I can fix it.
                
> Upgrade camel-guice to use guice 3.0
> ------------------------------------
>
>                 Key: CAMEL-4209
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4209
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-guice
>            Reporter: Willem Jiang
>             Fix For: Future
>
>         Attachments: camel_guice_3.0.diff
>
>
> As Guice 3.0 is released for a while, we should consider to upgrade the guice version
of camel-guice.
> Here is the thread[1] which discusses about it.
> [1]http://camel.465427.n5.nabble.com/camel-guice-td4565474.html

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message