camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CAMEL-5740) Upgrade to slf4j 1.7.2
Date Sat, 27 Oct 2012 16:13:12 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-5740?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13485464#comment-13485464
] 

Christian Müller commented on CAMEL-5740:
-----------------------------------------

Thanks for this hint Claus.

I checked my change and all bundles are using the right version range:
{noformat}
camel$ grep -r "slf4j;version=\"\[1.7" .
{noformat}

By working on this issue, I figured out an odd thing. After I added the OSGI import declaration
"org.eclipse.jetty.util.ssl;version="[7.6,8.2)";resolution:=optional" to the Camel parent
"camel.osgi.import.defaults" property a few weeks ago, this import was added into each Camel
bundle (I guess because it's optional). I think it's better to move this into the two Camel
components which are effected by this (camel-comedt and camel-websocket).
After this change, it's only imported by the bundles where it's needed:
{noformat}
camel$ grep -r "jetty.util.ssl;version" .
./components/camel-cometd/pom.xml:      org.eclipse.jetty.util.ssl;version="[7.6,8.2)";resolution:=optional,
./components/camel-websocket/pom.xml:   org.eclipse.jetty.util.ssl;version="[7.6,8.2)";resolution:=optional,
{noformat}

I also run the 
{noformat}
mvn clean install -Pvalidate
{noformat}
in platforms/karaf/features to make sure the imports could be resolved (there is an issue
in the camel-elasticsearch component which is not related to this change. If I remember right,
Babak spotted this issue a few days ago.).
                
> Upgrade to slf4j 1.7.2
> ----------------------
>
>                 Key: CAMEL-5740
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5740
>             Project: Camel
>          Issue Type: Task
>          Components: camel-core
>    Affects Versions: 2.9.4, 2.10.2
>            Reporter: Christian Müller
>            Assignee: Christian Müller
>            Priority: Minor
>             Fix For: 2.11.0
>
>
> As Karaf upgraded to slf4j 1.7.0 for Karaf 2.3.1, we may should also consider upgrading
to this version. See KARAF-1801

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message