camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-5418) camel-soap - Add support for SOAP 1.2
Date Thu, 05 Jul 2012 07:53:33 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-5418?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13406897#comment-13406897
] 

Claus Ibsen commented on CAMEL-5418:
------------------------------------

There is now a version attribute so you can set to "1.2" to use SOAP 1.2 when using XML DSL.
In Java DSL there is a jaxbsoap12 for using 1.2.

If creating the SoapJaxbDataFormat manually then there is a setVersion method.

Will fallback and use 1.1 if version not configured or some invalid value.
                
> camel-soap - Add support for SOAP 1.2
> -------------------------------------
>
>                 Key: CAMEL-5418
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5418
>             Project: Camel
>          Issue Type: New Feature
>          Components: camel-soap
>            Reporter: Claus Ibsen
>             Fix For: 2.11
>
>
> The camel-soap data format only supports SOAP 1.1.
> We should add support for SOAP 1.2 (it has a different namespace).
> And for that we may have to let the end user decide in the DLS if using soap 1.1 or 1.2,
as we may need to known this when we marshal (xml -> pojo).
> The trick would be that we would have 2 set of generated pojos based on soap 1.1 or 1.2.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message