camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Kulp (JIRA)" <>
Subject [jira] [Commented] (CAMEL-5223) Cannot find resource in classpath using OSGi blueprint
Date Thu, 26 Apr 2012 13:34:16 GMT


Daniel Kulp commented on CAMEL-5223:

I ran into this same issue with CXF's WS-N server on Tuesday.   The xsd's are in the cxf-wsn-api
bundle, but the cxf-wsn-core bundle could not load them even if importing the package.   The
ONLY solutions I found were:

1) Make cxf-wsn-core use a Dynamic-Import for the package that contains the resources.  A
normal import did not work, just the Dynamic-Import

2) Make cxf-wsn-core use a Require-Bundle: cxf-wsn-api

I'm not sure yet if this is a bug in the OSGi stuff.  (I also only checked with Felix, I need
to also check to see if Equinox exhibits the same issue)

> Cannot find resource in classpath using OSGi blueprint
> ------------------------------------------------------
>                 Key: CAMEL-5223
>                 URL:
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-blueprint
>    Affects Versions: 2.9.2
>         Environment: x86_64 GNU/Linux
> Java 1.6.0_26
> Apache ServiceMix 4.4.1
>            Reporter: Tobias Hofer
>             Fix For: 2.9.3, 2.10.0
>         Attachments: test-classpath-resource.tar.gz
> I switched from Apache Camel version 2.8.4 (in ServiceMix 4.4.1) to the most recent version
2.9.2. Resource loading in 2.8.4 worked well, but not in the named release.
> Find attached a small test case that uses XSLT and String-Template Endpoints. Neither
of them can load their resource from the separate bundle.
> # Install Apache ServiceMix 4.4.1
> # Configure ServiceMix to use Apache Camel 2.9.2 (see {{etc/org.apache.karaf.features.cfg}})
> # Start up ServiceMix
> # Install feature 'camel-string-template'
> # Build the attached test project using maven
> # Copy/Link the built artifact into the {{deploy}} folder
> # Copy/Link the route {{src/test/resources/camel-route}} into the {{deploy}} folder
> The XSLT Component tries to load the resource eagerly. Therefore the route will not start
and throws the following exception:
> {noformat}
> Caused by: Cannot find resource in classpath for URI:
> 	at org.apache.camel.util.ResourceHelper.resolveMandatoryResourceAsUrl(
> 	at org.apache.camel.component.xslt.XsltEndpoint.loadResource(
> {noformat}
> The same problem exists with the String-Template Component. But this component will fail
not until it is called in the route.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message