camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-5227) Camel 2.9.2 jetty component no longer works with Jetty 7
Date Fri, 27 Apr 2012 05:30:13 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-5227?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13263355#comment-13263355
] 

Claus Ibsen commented on CAMEL-5227:
------------------------------------

I am inclined to do the same on the Camel trunk as we are not supporting Jetty 8 currently.
Jetty is hard to upgrade as many other projects depend on it, CXF, AMQ, Karaf etc.
                
> Camel 2.9.2 jetty component no longer works with Jetty 7
> --------------------------------------------------------
>
>                 Key: CAMEL-5227
>                 URL: https://issues.apache.org/jira/browse/CAMEL-5227
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-jetty
>    Affects Versions: 2.9.2
>            Reporter: Scott Parkerson
>            Priority: Critical
>             Fix For: 2.9.3, 2.10.0
>
>
> When attempting to create a camel-jetty endpoint in Camel 2.9.2, the following exception
is thrown:
> {noformat}
> java.lang.NoSuchMethodError: org.eclipse.jetty.servlet.ServletContextHandler.addFilter(Lorg/eclipse/jetty/servlet/FilterHolder;Ljava/lang/String;Ljava/util/EnumSet;)V
> at org.apache.camel.component.jetty.JettyHttpComponent.enableMultipartFilter(JettyHttpComponent.java:407)
>     at org.apache.camel.component.jetty.JettyHttpComponent.connect(JettyHttpComponent.java:325)
>     at org.apache.camel.component.http.HttpEndpoint.connect(HttpEndpoint.java:148)
>     at org.apache.camel.component.http.HttpConsumer.doStart(HttpConsumer.java:56)
>     at org.apache.camel.support.ServiceSupport.start(ServiceSupport.java:60)
>     at org.apache.camel.impl.DefaultCamelContext.startService(DefaultCamelContext.java:1707)
>     at org.apache.camel.impl.DefaultCamelContext.doStartOrResumeRouteConsumers(DefaultCamelContext.java:1979)
>     at org.apache.camel.impl.DefaultCamelContext.doStartRouteConsumers(DefaultCamelContext.java:1934)
>     at org.apache.camel.impl.DefaultCamelContext.safelyStartRouteServices(DefaultCamelContext.java:1862)
>     at org.apache.camel.impl.DefaultCamelContext.doStartOrResumeRoutes(DefaultCamelContext.java:1646)
>     at org.apache.camel.impl.DefaultCamelContext.doStartCamel(DefaultCamelContext.java:1533)
>     at org.apache.camel.impl.DefaultCamelContext.doStart(DefaultCamelContext.java:1420)
>     at org.apache.camel.spring.SpringCamelContext.doStart(SpringCamelContext.java:179)
>     at org.apache.camel.support.ServiceSupport.start(ServiceSupport.java:60)
>     at org.apache.camel.impl.DefaultCamelContext.start(DefaultCamelContext.java:1388)
> .
> .
> .
> {noformat}
> This appears to be a regression of a caused by the [this merge from trunk|https://fisheye6.atlassian.com/changelog/camel?cs=1307901],
which I suspect requires Jetty 8 to be used.
> Creating the endpoint under 2.9.1 works fine.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message