camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (CAMEL-4778) Upgrade Spring to 3.1.0.RELEASE
Date Sun, 11 Mar 2012 11:53:59 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-4778?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13227034#comment-13227034
] 

Christian Müller commented on CAMEL-4778:
-----------------------------------------

I found the following incompatibilities between Spring 3.0 and Spring 3.1 which we have to
fix:
- org.apache.camel.test.spring.CamelSpringTestContextLoader extends org.springframework.test.context.support.AbstractContextLoader.
AbstractContextLoader implements org.springframework.test.context.SmartContextLoader (a new
interface since 3.1) which adds the new method "ApplicationContext loadContext(MergedContextConfiguration
mergedConfig)" which is not implemented by AbstractContextLoader.
                
> Upgrade Spring to 3.1.0.RELEASE
> -------------------------------
>
>                 Key: CAMEL-4778
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4778
>             Project: Camel
>          Issue Type: Task
>    Affects Versions: 2.8.3, 2.9.0
>            Reporter: Christian Müller
>            Assignee: Jean-Baptiste Onofré
>              Labels: spring
>
> We should consider to upgrade to Spring 3.1.0.RELEASE in Camel 2.10.0 or 3.0.0 depending
on the backwards compatibility of Spring.
> See: http://static.springsource.org/spring/docs/3.1.0.RELEASE/changelog.txt

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message