camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CAMEL-4840) Deprecate JUnit 3.x API from camel-test
Date Thu, 29 Dec 2011 08:53:30 GMT
Deprecate JUnit 3.x API from camel-test
---------------------------------------

                 Key: CAMEL-4840
                 URL: https://issues.apache.org/jira/browse/CAMEL-4840
             Project: Camel
          Issue Type: Task
          Components: camel-test
            Reporter: Claus Ibsen
             Fix For: 2.10


The camel-test component supports currently both JUnit 3.x and 4.x,
each in separate package.
Supporting both requires us to have a fair amount of duplicated code,
one for 3.x and another for 4.x.

I suggest to @deprecated the JUnit 3.x part of the camel-test component.
Then we can remove support for 3.x in Camel 3.0.


See nabble
http://camel.465427.n5.nabble.com/PROPOSAL-camel-test-deprecate-JUnit-3-x-API-tp5105436p5105436.html

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message