camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guillaume Nodet (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-4710) Upgrade to Karaf 3
Date Thu, 08 Dec 2011 08:17:40 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-4710?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13165080#comment-13165080
] 

Guillaume Nodet commented on CAMEL-4710:
----------------------------------------

Right, but I'd go further and not update for any 2.x version.  The reason is that due to the
range we use, we won't be able to deploy it on 
both karaf 2.x  and 3.x version (not with the commands at least, camel-core should deploy
fine).  So I think it would be better to keep Camel 2.x on Karaf 2.x and move Camel 3.x to
Karaf 3.x.
Another option would be to duplicate the karaf command module to have those available for
both Karaf 2.x and 3.x.
                
> Upgrade to Karaf 3
> ------------------
>
>                 Key: CAMEL-4710
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4710
>             Project: Camel
>          Issue Type: Task
>    Affects Versions: 2.9.0, 3.0.0
>            Reporter: Guillaume Nodet
>            Assignee: Jean-Baptiste Onofré
>             Fix For: 2.10, 3.0.0
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message