camel-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller (Closed) (JIRA) <j...@apache.org>
Subject [jira] [Closed] (CAMEL-4833) camel-spring-ws feature doesn't work
Date Wed, 28 Dec 2011 20:45:30 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-4833?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christian Müller closed CAMEL-4833.
-----------------------------------

    Resolution: Not A Problem

I added a notice to the Camel 2.9.0 release notes
                
> camel-spring-ws feature doesn't work
> ------------------------------------
>
>                 Key: CAMEL-4833
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4833
>             Project: Camel
>          Issue Type: Bug
>          Components: karaf
>    Affects Versions: 2.9.0
>            Reporter: Christian Müller
>            Priority: Critical
>              Labels: karaf, osgi, spring-ws
>             Fix For: 2.9.0
>
>
> Christian-Muellers-MacBook-Pro:bin cmueller$ /Applications/apache-karaf-2.2.5/bin/karaf
clean
>         __ __                  ____      
>        / //_/____ __________ _/ __/      
>       / ,<  / __ `/ ___/ __ `/ /_        
>      / /| |/ /_/ / /  / /_/ / __/        
>     /_/ |_|\__,_/_/   \__,_/_/         
>   Apache Karaf (2.2.5)
> Hit '<tab>' for a list of available commands
> and '[cmd] --help' for help on a specific command.
> Hit '<ctrl-d>' or 'osgi:shutdown' to shutdown Karaf.
> karaf@root> features:addurl mvn:org.apache.camel.karaf/apache-camel/2.9-SNAPSHOT/xml/features
> karaf@root> features:install camel-spring-ws 
> 2011-12-27 22:57:32.760:INFO:oejs.Server:jetty-7.5.4.v20111024
> 2011-12-27 22:57:32.789:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:8181
STARTING
> Error executing command: Could not start bundle mvn:org.springframework.ws/spring-ws-core/2.0.3.RELEASE
in feature(s) camel-spring-ws-2.9-SNAPSHOT: Unable to resolve module org.springframework.ws
[100.0] because it is exposed to package 'javax.activation' from org.apache.felix.framework
[0] and org.apache.servicemix.specs.activation-api-1.1 [63.0] via two dependency chains.
> Chain 1:
>   org.springframework.ws [100.0]
>     import: (&(package=javax.activation)(version>=0.0.0))
>      |
>     export: package=javax.activation
>   org.apache.felix.framework [0]
> Chain 2:
>   org.springframework.ws [100.0]
>     import: (&(package=org.springframework.oxm.mime)(version>=3.0.6)(!(version>=4.0.0)))
>      |
>     export: package=org.springframework.oxm.mime; uses:=javax.activation
>   org.springframework.oxm [97.0]
>     import: (&(package=javax.activation)(version>=0.0.0))
>      |
>     export: package=javax.activation
>   org.apache.servicemix.specs.activation-api-1.1 [63.0]

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message