camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: camel-spring-dm feature incompatible to most other features of camel 2.18.3
Date Wed, 12 Apr 2017 11:54:56 GMT
Hi

Just in case we going to disable it so its not in the features file.
But the JAR is still build and released

Then it can be dropped/removed totally in 2.20 or 3.0 at the latest.



On Tue, Apr 11, 2017 at 3:41 PM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
> Hi
>
> Just a heads up that as spring-dm is almost impossible to get working
> anymore in a modern karaf / osgi world so we will remove it from 2.19
> onwards.
>
>
>
> On Thu, Mar 23, 2017 at 6:50 PM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
>> Logged a ticket
>> https://issues.apache.org/jira/browse/CAMEL-11059
>>
>> On Thu, Mar 23, 2017 at 6:01 PM, Christian Schneider
>> <chris@die-schneider.net> wrote:
>>> I also think removing spring dm for camel 2.19 is a good idea.
>>> Currently people just mix camel-spring-dm with any other camel features and
>>> expect it to work. So they can only be disappointed.
>>>
>>> Christian
>>>
>>>
>>> On 23.03.2017 17:50, Claus Ibsen wrote:
>>>>
>>>> I think you can run camel-spring-dm and maybe not install components
>>>> that require Spring 4.x etc and then do some limited Camel application
>>>> on the legacy Spring DM. Or in theory have spring 3.x and 4.x run side
>>>> by side (osgi versioning) and have it somehow work. But hey f...
>>>> spring-dm is not good in osgi. Use blueprint!
>>>>
>>>> But yeah its totally deprecated and people should move off spring-dm
>>>> asap if possible.
>>>>
>>>> gnodet talked about some work they do in karaf to make it possible to
>>>> load spring xml files and then automatic transform that into
>>>> blueprint, so people could use spring xml files but it would run as
>>>> blueprint.
>>>>
>>>> We could consider removing camel-spring-dm from Camel 2.19 onwards if
>>>> it makes too much trouble.
>>>>
>>>>
>>>> On Thu, Mar 23, 2017 at 2:44 PM, Christian Schneider
>>>> <chris@die-schneider.net> wrote:
>>>>>
>>>>> Camel 2.18.3 seems to have upgraded most camel modules to spring 4.
>>>>> The only exemption is the camel-spring-dm feature which depends on spring
>>>>> <
>>>>> 4.
>>>>>
>>>>> As far as I know this causes camel 2.18.3 to not work on karaf when using
>>>>> camel-spring-dm with any of the other camel modules that require spring
>>>>> 4.
>>>>> Do others have the same experience?
>>>>>
>>>>> What is our position about this as a community? Can we somehow upgrade
>>>>> spring-dm to spring 4 or is it simply impossible to use it now?
>>>>>
>>>>> In case we can not make it work I propose to remove the camel-spring-dm
>>>>> feature so users know that it is not supported any more.
>>>>>
>>>>> Christian
>>>>>
>>>>> --
>>>>> Christian Schneider
>>>>> http://www.liquid-reality.de
>>>>>
>>>>> Open Source Architect
>>>>> http://www.talend.com
>>>>>
>>>>
>>>>
>>>
>>>
>>> --
>>> Christian Schneider
>>> http://www.liquid-reality.de
>>>
>>> Open Source Architect
>>> http://www.talend.com
>>>
>>
>>
>>
>> --
>> Claus Ibsen
>> -----------------
>> http://davsclaus.com @davsclaus
>> Camel in Action 2: https://www.manning.com/ibsen2
>
>
>
> --
> Claus Ibsen
> -----------------
> http://davsclaus.com @davsclaus
> Camel in Action 2: https://www.manning.com/ibsen2



-- 
Claus Ibsen
-----------------
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2

Mime
View raw message