camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antonin Stefanutti <anto...@stefanutti.fr>
Subject Re: CDI?
Date Thu, 13 Apr 2017 07:40:52 GMT
Hi,

The dependency on DeltaSpike from Camel CDI has been removed starting Camel 2.17.0. So I would
not expect it to be a problem with Camel / PAX CDI.

Antonin

> On 12 Apr 2017, at 20:59, Guillaume Nodet <gnodet@apache.org> wrote:
> 
> 2017-04-12 20:52 GMT+02:00 Ranx <ranx@enjekt.org>:
> 
>> I'm not quite sure I follow the comments on this issue.
>> 
>> 
>> 
>> https://issues.apache.org/jira/browse/CAMEL-11029
>> 
>> 
>> 
>> According to the Camel documentation there seems to be a lot of work being
>> done on the Camel CDI in 2.18 so how can it simultaneously be deprecated?
>> 
>> 
>> 
>> http://camel.apache.org/cdi.html
>> 
>> 
>> 
>> It's possible I'm misunderstanding this somehow and that the deprecation is
>> due to a difference in Camel and the later versions of Karaf? Or does this
>> have to do with Guillaume's new PAX DS implementation of CDI?
>> 
> 
> I think there are some problems around pax-cdi + deltaspike.  I haven't had
> any time to actually investigate those though.  Maybe those are the reason
> for Claus' comment ?
> 
> 
>> 
>> 
>> 
>> Thanks for any clarification.
>> 
>> 
>> 
>> Ranx
>> 
>> 
> 
> 
> -- 
> ------------------------
> Guillaume Nodet


Mime
View raw message