camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zregvart <...@git.apache.org>
Subject [GitHub] camel pull request #1307: CAMEL-10519 Disable TLSv1.0 in camel-salesforce
Date Thu, 24 Nov 2016 12:56:04 GMT
GitHub user zregvart opened a pull request:

    https://github.com/apache/camel/pull/1307

    CAMEL-10519 Disable TLSv1.0 in camel-salesforce

    This commit adds a warning message if the used JSSE implementation does
    not support TLS version 1.1 or newer. TLS version 1.0 is disabled by
    default and additionaly all SSL versions are disabled -- which is done
    by default in BaseSSLContextParameters, so its added here so that the
    new default configuration does not override and allow SSL versions.
    
    The main purpose of this commit is to allow users that are using Java 7
    without support for TLS version 1.1 or newer, i.e. not using Oracle or
    IBM Java or using custom SSL configuration with custom JSSE provider
    that is configured or does not support TLS version 1.1 or newer --
    to get an early warning (before March, 2017 when Salesforce disables TLS
    version 1.0). And to set default enabled SSL protocols to TLS version
    1.1 and onward.

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/zregvart/camel CAMEL-10519-camel-2.17.x

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/camel/pull/1307.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1307
    
----
commit 887627bd8fcf20c7b2575176c6257233fb0d21a8
Author: Zoran Regvart <zoran@regvart.com>
Date:   2016-11-24T11:12:21Z

    CAMEL-10519 Disable TLSv1.0 in camel-salesforce
    
    This commit adds a warning message if the used JSSE implementation does
    not support TLS version 1.1 or newer. TLS version 1.0 is disabled by
    default and additionaly all SSL versions are disabled -- which is done
    by default in BaseSSLContextParameters, so its added here so that the
    new default configuration does not override and allow SSL versions.
    
    The main purpose of this commit is to allow users that are using Java 7
    without support for TLS version 1.1 or newer, i.e. not using Oracle or
    IBM Java or using custom SSL configuration with custom JSSE provider
    that is configured or does not support TLS version 1.1 or newer --
    to get an early warning (before March, 2017 when Salesforce disables TLS
    version 1.0). And to set default enabled SSL protocols to TLS version
    1.1 and onward.

----


---
If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at infrastructure@apache.org or file a JIRA ticket
with INFRA.
---

Mime
View raw message