camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: help about camel-package-maven-plugin
Date Sat, 30 Jul 2016 11:00:12 GMT
A good idea is to not load all the Camel source code (as there is too
much) but open the component(s) you are working on.

Your Eclipse problem is of a general problem you can maybe find help
on the internet how to setup Eclipse with Java and the tools.jar.

The camel-etcd component do NOT use the maven-antrun-plugin which is
the error you have, so it smells like a Eclipse issue.




On Sat, Jul 30, 2016 at 12:31 PM, onders
<ondersezgin+cameluser@gmail.com> wrote:
> thanks. it seems working when trying to build 2.17.X
> however, i did upgrade my java version to 1.8.0_102.
> then now upgraded my git clone to master and tried rebuilding the source
>
> now the error is like my tools.jar file is missing;
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-antrun-plugin:1.6:
> run (setup.workspace) on project camel-etc: Execution setup.workspace of
> goal or
> g.apache.maven.plugins:maven-antrun-plugin:1.6:run failed: Plugin
> org.apache.mav
> en.plugins:maven-antrun-plugin:1.6 or one of its dependencies could not be
> resol
> ved: Could not find artifact com.sun:tools:jar:1.5.0 at specified path
> D:\PFs\ja
> va\jdk1.8.0_102/../lib/tools.jar -> [Help 1]
>
> anyone had such issue with java 8 tools.jar file?
>
> Thanks
>
>
>
> --
> View this message in context: http://camel.465427.n5.nabble.com/help-about-camel-package-maven-plugin-tp5785542p5785702.html
> Sent from the Camel Development mailing list archive at Nabble.com.



-- 
Claus Ibsen
-----------------
http://davsclaus.com @davsclaus
Camel in Action 2: https://www.manning.com/ibsen2

Mime
View raw message