camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <>
Subject [HEADS UP] - Camel 2.17 and Apache Karaf changes
Date Sat, 12 Mar 2016 12:53:07 GMT

I have worked on improving the installation of Camel on Karaf to make
it rely on newer versions of Spring. It could install and use the old
spring 3.x libraries which was annoying when the entire world is using
Spring 4.2 or 4.1 etc.

So what I have done

feature:install camel

will only install camel-core and camel-blueprint. camel-spring is not
longer installed by default as camel-spring uses spring-dm which loads
in Spring 3.2.x.
spring-dm is deprecated, and we want in Camel 2.18 to move spring-dm
out of camel-spring into a new camel-spring-dm module. Then the
camel-spring module can be a spring 4.x only.

other features that uses spring libraries are not installing
camel-spring but instead using the spring features from karaf. That
helps to use the current spring version and not install spring 3.x due
to camel-spring bring that in due dm (see a)

make some of the camel-spring-xxx modules that requires spring 4.x to
have proper version range in the osgi manifest so they can be
installed reliable and use spring 4.x as intended.

The used spring-range is [4.1,5) which mean it supports the default
spring version that karaf install in karaf 2.4 / 3.x and 4.x all
together. However in Camel 2.18 we change this to [4.2,5) as we drop
support for both spring 4.0 and 4.1 all together.

I got the tests/camel-itest-karaf to work again - after much hard work.
You can run the tests against 3 different karaf containers

mvn clean install
mvn clean install -Pkaraf3
mvn clean install -Pkaraf4

We will in Camel 2.18 drop support for karaf 2.4.x and (maybe 3.x
also) and make those tests use karaf 4 by default.

Any Karaf users with Camel. Its your chance to help testing and
provide feedback.

Claus Ibsen
----------------- @davsclaus
Camel in Action 2:

View raw message