camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tadayoshi Sato <sato.tadayo...@gmail.com>
Subject Why are UnsafeUriCharactersEncoder duplicated?
Date Fri, 26 Feb 2016 03:09:51 GMT
Hello Camel experts,

I found that there are two UnsafeUriCharactersEncoder classes in the Camel
codebase, one is in camel-core and another is in camel-catalog, and they
are almost identical.

Is there any reason these classes need to be duplicated?  I like DRY :-)
 Is it possible to remove the camel-catalog version (or perhaps annotate it
@Deprecated) and solely use the camel-core version in the codebase?

I appreciate your advices. Thanks!

Tadayoshi

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message