camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cdacjayesh <jay...@cdac.in>
Subject Received sun.net.www.protocol.http.httpurlconnection$httpinputstream as response while calling service which is unable to process
Date Fri, 18 Dec 2015 05:06:07 GMT
I'm developing workflow application in Apache camel
Business Use case:
1.Service is exposed at consumer endpoint
2.Processing with request message
3.Call external SOAP Service, get the response
4.check particular tag in response xml and then only call another external
SOAP Service
5.Return the final response to client
Now I got stuck in step 4
My camel Route is
<camelContext xmlns="http://camel.apache.org/schema/spring">
    <route streamCache="true">
      <from uri="cxf:bean:proxyEndpoint"/>
        <process ref="myProcessor"/>
             
      <setBody>
             
      </setBody>
      <to uri="cxf:bean:panEndpoint"/>
      
      
      <log message="&gt;&gt;&gt; ${body}" loggingLevel="INFO"/> 
    </route>
  </camelContext>
I'm able to call external Service but after <to uri="cxf:bean:panEndpoint"/>
if I try to log body I'm getting arbitrary value same in case of routing to
file.
When I tried to route to Processor and print
System.out.println(exchange.getIn().getBody()); I'm getting
sun.net.www.protocol.http.httpurlconnection$httpinputstream which I'm unable
to parse or process
External Service is called and proper response is receiving as I tried to
monitor the scenario using TCP-IP Monitor

Any help will be appreciated.



--
View this message in context: http://camel.465427.n5.nabble.com/Received-sun-net-www-protocol-http-httpurlconnection-httpinputstream-as-response-while-calling-servis-tp5775238.html
Sent from the Camel Development mailing list archive at Nabble.com.

Mime
View raw message