camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Camel 2.16 or 2.17 and Karaf 2.4.x to be dropped?
Date Mon, 13 Jul 2015 13:59:02 GMT

This makes sense to me.   

That said, moving to Karaf 3.0 doesn’t get rid of jetty8.  Need 4.0 for that.   :-) 

Dan


> On Jul 13, 2015, at 6:35 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:
> 
> Hi
> 
> I wonder if its time we move on master branch of Camel to require a
> newer version of Apache Karaf?
> 
> Maybe Camel 2.16 should be the last release where we test and support
> with Karaf 2.4.
> And then move on for next release to be Karaf 3.0+.
> 
> This helps us move away from the old EOL version of Jetty 8. And use
> Jetty9+ onwards.
> 
> And also move on as we cannot support old software forever.
> 
> 
> 
> 
> -- 
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: cibsen@redhat.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
> hawtio: http://hawt.io/
> fabric8: http://fabric8.io/

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message