camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Camel MongoDB : Remove option invokeGetLastError
Date Mon, 30 Mar 2015 09:28:54 GMT
Hi

Great to hear about your work.

Yeah we can mark an option as deprecated on, saying its deprecated and
to be removed in eg Camel 2.16 etc if that is the version where we
upgrade to driver version 3
http://camel.apache.org/mongodb

If you have a suggest for the wording we can add it.

Or if you want to be able to edit the website you follow this guide
http://camel.apache.org/how-do-i-edit-the-website.html



On Sun, Mar 29, 2015 at 9:11 PM, Dewitte Pierre-Alban
<padewitte@gmail.com> wrote:
> Hi,
>
> I currently trie to remove all deprecated use of MongoDB Java driver to
> ease the migration from 2.13 to 3.0 when it will be realease.
>
> Since version 2.13 of Java Driver, lt of method in WriteResult object are
> deprecated https://api.mongodb.org/java/2.13/com/mongodb/WriteResult.html .
> As explain, the MongoClient should relie on the write concern and not use
> the getLastError or getCachedLastError. If my french is good
> the invokeGetLastError option of the component is also useless and we
> should invite people to use the right write concern.
>
> How do you manage such a case in Camel ? Is it possible to depreciate a
> attribute to remove it in a further version ? Do you remove it immediatly ?
> Do we keep it but with no effect ?
>
> Thanks for you replie.
>
> Pierre-Alban DEWITTE
> @__pad__



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
Email: cibsen@redhat.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen
hawtio: http://hawt.io/
fabric8: http://fabric8.io/

Mime
View raw message