camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: Switch the default Spring version to Spring 4.x
Date Sun, 14 Sep 2014 13:29:10 GMT
Today I checked the current trunk (2.15-SNAPSHOT) and realized that 6
components will not work with Spring 4 nicely at present:
- camel-spring-ws
- camel-spring-security
- camel-spring-redis
- camel-spring-integration
- camel-spring-batch
- camel-olingo2

I suggest to stick to Spring 3.2.x for Camel 2.14.0 and do the Spring 4
upgrade (4.0.x or 4.1.x) in Camel 2.15.0.

Best,
Christian
-----------------

Software Integration Specialist

Apache Member
V.P. Apache Camel | Apache Camel PMC Member | Apache Camel committer
Apache Incubator PMC Member

https://www.linkedin.com/pub/christian-mueller/11/551/642

On Fri, Sep 12, 2014 at 3:47 AM, Willem Jiang <willem.jiang@gmail.com>
wrote:

> Hi,
>
> Because spring-test 4.x is not backward compatible, we have to create
> camel-test-spring and camel-test-spring3 module for spring 4.x and spring
> 3.x.
>
> Current camel default version of Spring is 3.2.x, if not easy for the user
> who still want to camel-test-spring to upgrade.
>
> So my suggestion is we switch the default version of spring to 4.x, and
> ask the user to manage the all the spring dependency in his pom.
>
> Any thought?
>
>
> --
> Willem Jiang
>
> Red Hat, Inc.
> Web: http://www.redhat.com
> Blog: http://willemjiang.blogspot.com (English)
> http://jnn.iteye.com (Chinese)
> Twitter: willemjiang
> Weibo: 姜宁willem
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message