camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré ...@nanthrax.net>
Subject Re: Camel contributions - which Java version to code to?
Date Tue, 16 Sep 2014 11:01:29 GMT
Hi Antoine,

if you plan to merge your change on version previous to 2.14, you have 
to use Java6.

Regards
JB

On 09/15/2014 10:15 AM, Antoine DESSAIGNE wrote:
> Hi Claus,
>
>  From now on, we can use the java7 features in the code ?
> (try-with-resource, etc...)
>
> Antoine.
>
> 2014-09-13 7:35 GMT+02:00 Claus Ibsen <claus.ibsen@gmail.com>:
>
>> Java 7
>>
>> On Fri, Sep 12, 2014 at 9:48 PM, rickaroni <rgfanta@directv.com> wrote:
>>> Hiya,
>>>
>>> Should I assume from this link that all Camel contribution code has to be
>>> Java 6 compatible?
>> http://camel.apache.org/what-are-the-dependencies.html
>>> <http://camel.apache.org/what-are-the-dependencies.html>
>>>
>>> That is, I'd like to change a component such that Joda DateTime is
>> replaced
>>> by the new Java 8 OffsetDateTime.  Is it kosher to do that but provide a
>> JSR
>>> 310 backport via a maven dependency like this?
>>>
>> http://mvnrepository.com/artifact/com.fasterxml.jackson.datatype/jackson-datatype-jsr310/2.4.2
>>> <
>> http://mvnrepository.com/artifact/com.fasterxml.jackson.datatype/jackson-datatype-jsr310/2.4.2
>>>
>>>
>>> Thanks,
>>> Rick
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> --
>>> View this message in context:
>> http://camel.465427.n5.nabble.com/Camel-contributions-which-Java-version-to-code-to-tp5756456.html
>>> Sent from the Camel Development mailing list archive at Nabble.com.
>>
>>
>>
>> --
>> Claus Ibsen
>> -----------------
>> Red Hat, Inc.
>> Email: cibsen@redhat.com
>> Twitter: davsclaus
>> Blog: http://davsclaus.com
>> Author of Camel in Action: http://www.manning.com/ibsen
>> hawtio: http://hawt.io/
>> fabric8: http://fabric8.io/
>>
>

-- 
Jean-Baptiste Onofré
jbonofre@apache.org
http://blog.nanthrax.net
Talend - http://www.talend.com

Mime
View raw message