camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@gmail.com>
Subject Re: problem with current 2.14-SNAPSHOT on karaf-3.0.1?
Date Wed, 06 Aug 2014 09:44:22 GMT
I just saw some messages on dev@karaf.

I could try replacing Jline manually in karaf-3.0.1 for now.


2014-08-06 11:26 GMT+02:00 Aki Yoshida <elakito@gmail.com>:
> I am getting this error when using camel feature for 2.14-SNAPSHOT on
> karaf-3.0.1.
>
> Error executing command: Could not start bundle
> mvn:org.apache.camel.karaf/camel-karaf-commands/2.14-SNAPSHOT in
> feature(s) camel-core-2.14-SNAPSHOT: Unresolved constraint in bundle
> org.apache.camel.karaf.camel-karaf-commands [85]: Unable to resolve
> 85.0: missing requirement [85.0] osgi.wiring.package;
> (&(osgi.wiring.package=jline.console.completer)(version>=2.12.0)(!(version>=3.0.0)))
>
> I noticed that karaf-3.0.1 comes with jline 2.11.
>
> karaf@root()> list -t 0 | grep JLine
> 26 | Active   |  30 | 2.11.0                | JLine
>
> but org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.6 is
> asking for jline 2.12.
>
> camel-2.14-SNAPSHOT has recently upgraded to use karaf 2.3.6.
> https://git-wip-us.apache.org/repos/asf?p=camel.git;a=commit;h=14cb8b1c6afcbf7b2e13252e7c4b90d85909f013
>
> Is there a simple workaround for this? I'm not sure if something was
> messed up on my system or if this is an issue.
>
> And if this is an issue, I don't know if we are supposed to add jline
> 2.12 in the camel's feature or revert this 2.3.6 upgrade?
>
> regards, aki

Mime
View raw message