camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cristiano Costantini <cristiano.costant...@gmail.com>
Subject camel-protobuf and protobuf 2.5
Date Sun, 16 Mar 2014 10:21:29 GMT
Hi All,

I see that the camel-protobuf karaf feature is using protobuf 2.3:

karaf@root> features:info camel-protobuf
Description of camel-protobuf 2.12.3 feature
----------------------------------------------------------------
Feature has no configuration
Feature has no configuration files
Feature depends on:
  camel-core 2.12.3
Feature contains followed bundles:
 mvn:org.apache.servicemix.bundles/org.apache.servicemix.bundles.protobuf-java/2.3.0_3
start-level=50
 mvn:org.apache.camel/camel-protobuf/2.12.3 start-level=50


As I use protobuf 2.5.0, I've tried manually to install latest protobuf
(note it is natively OSGi):
install -s mvn:com.google.protobuf/protobuf-java/2.5.0

and then manually install camel-protobuf:
install -s mvn:org.apache.camel/camel-protobuf/2.12.3


This is an empirical test but I then was able to successfully unmarshal (
https://github.com/cristcost/sensormix/blob/master/sensormix-integration-bundle/src/main/resources/META-INF/spring/beans-routes.xml#L65)
the class generated using protobuf 2.5.0 (
https://github.com/cristcost/sensormix/blob/master/sensormix-integration-bundle/src/main/java/com/google/developers/gdgfirenze/protobuf/SensormixProtos.java
)

I wonder why the feature is still installing protobuf 2.3.0 and what else
could be missing to upgrade it. ;-)

Regards,
Cristiano

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message