camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Willem Jiang <willem.ji...@gmail.com>
Subject Re: [VOTE] Release Apache Camel 2.12.3
Date Thu, 20 Feb 2014 01:44:07 GMT
Hi Hadrian,

I released the Camel 2.12.0 with JDK 1.7, as the compile plugin is set the source and target
with 1.6, I don’t get any complain about it.

As I had said the HTML documentation issue could cause some trouble when some tools to load
camel bundles, I changed my vote to -1. We need to recut the kit with JDK 1.7.

--  
Willem Jiang

Red Hat, Inc.
Web: http://www.redhat.com
Blog: http://willemjiang.blogspot.com(http://willemjiang.blogspot.com/) (English)
http://jnn.iteye.com(http://jnn.javaeye.com/) (Chinese)
Twitter: willemjiang  
Weibo: 姜宁willem



On February 19, 2014 at 11:39:13 PM, Hadrian Zbarcea (hzbarcea@gmail.com) wrote:
>  
> Babak, per the ASF policy we can release 2.12.3 even with -1s.  
> However, I usually shoot for consensus. Here's what I am going  
> to do in
> this case, because yours is the only -1 with an overwhelming majority  
> of
> +1s. I'll give it another 12 hours and if nothing changes I will  
> close
> the vote and release 2.12.3. If within this time you convince  
> another
> PMC member to change his vote I will cancel this vote.
>  
> We had two releases in the past, years ago (1.4 and 1.5 time) that  
> were
> built with a newer version that the oldest supported and we got  
> burned
> by the version of the class file format. (I was the one who messed  
> up,
> had to redo the releases and learned my lesson). I personally  
> don't
> release with a newer java version than the oldest supported.  
>  
> Cheers,
> Hadrian
>  
> [1] http://www.apache.org/dev/release.html
>  
>  
> On 02/19/2014 10:19 AM, Babak Vahdat wrote:
> > Hi Harian,
> >
> > I'm actually still -1 to this release candidate as the HTML documentation  
> > inside the bundles are missing (as a side effect of Java 6 being  
> used for
> > building instead of Java 7). This requirement has been clearly  
> stated inside
> > our release guides (yes, I was the one who added that note):
> >
> > http://camel.apache.org/release-guide.html
> >
> > And we've also discussed this many times @ the dev-forum as well:  
> >
> > http://camel.465427.n5.nabble.com/improving-Endpoint-documentation-and-tooling-td5731334.html
 
> > http://camel.465427.n5.nabble.com/Our-builds-looks-really-bad-tp5731673p5731743.html
 
> >
> > That all said, I may sound too pedantic, sorry for that!
> >
> > Last but not least I ask for apologies by the Apache Camel PMC  
> because of
> > the STUPID mistake I made while voting for the 2.11.4 release  
> candidate:
> >
> > http://camel.465427.n5.nabble.com/VOTE-Release-Apache-Camel-2-11-4-tp5747362p5747430.html
 
> >
> > As I had A LOT OF BEERS the night before that vote of mine. So I guess  
> that
> > was why my brain went terribly wrong :)
> >
> > Many thanks for your effort to prepare these two release candidates!  
> >
> > Babak
> >
> >
> > hadrian wrote
> >> Babak,
> >>
> >> We're past the 72 hours mark and I would like to close this vote  
> with a
> >> consensus is possible. Do you still think we have an issue,  
> or you want
> >> to consider reverting your vote?
> >>
> >> Cheers,
> >> Hadrian
> >>
> >>
> >> On 02/17/2014 05:06 AM, Babak Vahdat wrote:
> >>> Hi Willem,
> >>>
> >>> can you please elaborate your explanation a bit? Currently  
> what we've on
> >>> the
> >>> 2.12.x. as well as 2.11.x branches is this:
> >>>
> >>>
> >>  
> >> 2.7.10
> >>  
> >>>
> >>  
> >> [2.6,2.9)
> >>  
> >>> Now to my understanding this should become:
> >>>
> >>>
> >>  
> >> 2.7.10
> >>  
> >>>
> >>  
> >> [2.6,3)
> >>  
> >>> I think the current range is a problem for the OSGi folks because  
> if e.g.
> >>> there's a bug-fix being provided in CXF 2.7.10, currently  
> they can't
> >>> force
> >>> the Container to make use of CXF 2.7.10 while they install  
> the
> >>> "camel-cxf"
> >>> feature version 2.12.3 or 2.11.4 (e.g. in the context of a  
> dependency of
> >>> their own Karaf feature "my-cool-app-karaf-feature")  
> because the current
> >>> range does NOT include 2.7.10.
> >>>
> >>> Babak
> >>>
> >>>
> >>> Willem.Jiang wrote
> >>>> There are some patches of supporting CXF 3.x are not merged  
> to
> >>>> camel-2.12.x and camel-2.11.x.
> >>>> So the cxf version rang of camel-2.12.x and camel-2.11.x  
> is right.
> >>>>
> >>>> I don’t think it’s a show-stopper.
> >>>>
> >>>> --
> >>>> Willem Jiang
> >>>>
> >>>> Red Hat, Inc.
> >>>> Web: http://www.redhat.com
> >>>> Blog: http://willemjiang.blogspot.com(http://willemjiang.blogspot.com/)
 
> >>>> (English)
> >>>> http://jnn.iteye.com(http://jnn.javaeye.com/) (Chinese)  
> >>>> Twitter: willemjiang
> >>>> Weibo: 姜宁willem
> >>>>
> >>>>
> >>>>
> >>>> On February 16, 2014 at 11:35:56 PM, Babak Vahdat (
> >>>> babak.vahdat@
> >>>> ) wrote:
> >>>>>
> >>>>> O.K. the build has been definetly done using Java 6 as this's  
> how
> >>>>> MANIFEST.MF
> >>>>> of camel-core-2.12.3.jar looks like:
> >>>>>
> >>>>> Manifest-Version: 1.0
> >>>>> Bnd-LastModified: 1392475192207
> >>>>> Build-Jdk: 1.6.0_45
> >>>>> Built-By: hadrian
> >>>>> ...
> >>>>>
> >>>>>
> >>>>> Other than that the backport of the fix for CAMEL-7170 did  
> NOT
> >>>>> adjust the
> >>>>> maven property accordingly, so on the
> >>>>> master branch
> >>>>> we've got:
> >>>>>
> >>>>> 2.7.10
> >>>>> [2.6,4.0)
> >>>>>
> >>>>> Which is fine, however on the 2.12.x as well as the 2.11.x  
> branch
> >>>>> we've got:
> >>>>>
> >>>>> 2.7.10
> >>>>> [2.6,2.9)
> >>>>>
> >>>>> So here's my -1
> >>>>>
> >>>>> Babak
> >>>>>
> >>>>>
> >>>>> Babak Vahdat wrote
> >>>>>> Hi
> >>>>>>
> >>>>>> The HTML component documentation inside the JARs are  
> missing.
> >>>>> I assume
> >>>>>> Java 6 has been used for building this release candidate.  
> See
> >>>>> also the
> >>>>>> first "Note" @ http://camel.apache.org/release-guide.html  
> >>>>>>
> >>>>>> Babak
> >>>>>> hadrian wrote
> >>>>>>> This is a vote to release Apache Camel 2.12.3, a patch 

> release
> >>>>> coming
> >>>>>>> with about 128 issues fixed.
> >>>>>>>
> >>>>>>> Release notes:
> >>>>>>>
> >>>>> https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311211&version=12325593
 
> >>>>>>> Staging repo:
> >>>>>>> https://repository.apache.org/content/repositories/orgapachecamel-1002
 
> >>>>>>>
> >>>>>>> Tarballs:
> >>>>>>>
> >>>>> https://repository.apache.org/content/repositories/orgapachecamel-1002/org/apache/camel/apache-camel/2.12.3/
 
> >>>>>>> Tag:
> >>>>>>>
> >>>>> https://git-wip-us.apache.org/repos/asf?p=camel.git;a=tag;h=4bf31d2e2cbc34fda60d68c0dd33cb39d63ba1c6
 
> >>>>>>> Please test this release candidate and cast your vote. 

> >>>>>>> [ ] +1 Release the binary as Apache Camel 2.12.3
> >>>>>>> [ ] -1 Veto the release (provide specific comments)
> >>>>>>> Vote is open for at least 72 hours.
> >>>>>>>
> >>>>>>> Thanks,
> >>>>>>> Hadrian
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>>
> >>>>> --
> >>>>> View this message in context:
> >>>>> http://camel.465427.n5.nabble.com/VOTE-Release-Apache-Camel-2-12-3-tp5747361p5747375.html
 
> >>>>> Sent from the Camel Development mailing list archive at  
> Nabble.com.
> >>>>>
> >>>
> >>>
> >>>
> >>> --
> >>> View this message in context:
> >>> http://camel.465427.n5.nabble.com/VOTE-Release-Apache-Camel-2-12-3-tp5747361p5747421.html
 
> >>> Sent from the Camel Development mailing list archive at Nabble.com.  
> >
> >
> >
> >
> > --
> > View this message in context: http://camel.465427.n5.nabble.com/VOTE-Release-Apache-Camel-2-12-3-tp5747361p5747563.html
 
> > Sent from the Camel Development mailing list archive at Nabble.com.  
>  
>  


Mime
View raw message