camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Karlsen <davidkarl...@gmail.com>
Subject Re: [DISCUSS] - Drop Spring 3.1 support in Camel 2.13 onwards
Date Mon, 03 Feb 2014 14:09:44 GMT
Sounds good to me.
And also if one take into consideration moving onto spring 4.x as well:
https://issues.apache.org/jira/browse/CAMEL-7074



2014-02-03 Claus Ibsen <claus.ibsen@gmail.com>:

> Hi
>
> In Camel 2.12 we dropped support for Spring 3.0. But shipped and
> tested with Spring 3.1.
>
> For Camel 2.13 we could drop support for Spring 3.1. And being shipped
> and tested with Spring 3.2.
>
> One reason would be that if we have spring 3.2 as minimum then we can
> use some of the new APIs it has for better controlling
> startup|shutdown of Camel in Spring apps.
>
> One issue logged recently is
> https://issues.apache.org/jira/browse/CAMEL-7156
>
> Also Spring 3.1 is EOL and SpringSource. So IMHO I think its okay for
> us to move on as well.
>
> Any thoughts?
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: cibsen@redhat.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
> Make your Camel applications look hawt, try: http://hawt.io
>



-- 
--
David J. M. Karlsen - http://www.linkedin.com/in/davidkarlsen

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message