camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@gmail.com>
Subject Re: import version range for javax.servlet in camel-servlet et al
Date Tue, 26 Nov 2013 16:37:29 GMT
Hi Christian,
thanks for your feedback.
In the affected environment that I have is based on gemini-web and
tomcat, where only the servlet 3.0 version is exported. So,
camel-servlet doesn't get activated out of the box. Simply changing
the import range will make it wired and also functional. So, I'll be
adding the range.

regards, aki



2013/11/26 Christian Schneider <chris@die-schneider.net>:
> We can do this but I think it is not necessary.
> Implementations like pax web support the old package versions too to be
> compatible with old builds.
>
> Christian
>
> Am 26.11.2013 12:39, schrieb Aki Yoshida:
>
>> Hi,
>> I noticed this a while ago but forgot to bring it up or ask.
>>
>> Currently, the import version range of javax.servlet is not explicitly
>> given in camel-servlet's pom and as a result, camel-servlet is
>> importing javax.servlet with range "[2.6,3)".
>>
>> Could we set the range explicitly to something like "[2.6, 4)" in pom
>> so that we can allow 3.0 out of the box?
>>
>> thanks.
>> regards, aki
>
>
>
> --
>  Christian Schneider
> http://www.liquid-reality.de
>
> Open Source Architect
> Talend Application Integration Division http://www.talend.com
>

Mime
View raw message