camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: Feature installation of 'camel-extra' component 'camel-spring-neo4j'
Date Fri, 20 Sep 2013 06:28:05 GMT
Will have a look at the weekend.

Best,
Christian
Am 20.09.2013 07:57 schrieb "Christoph Emmersberger" <
cemmersb@googlemail.com>:

> Dear all,
>
> I'm currently facing some issues when installing the 'camel-spring-neo4j'
> component, currently available as 2.11-SNAPSHOT version. I've seen, that
> the feature is incomplete, and wanted to fix this. However, it turns out,
> when resolving one dependency, the next pulls.
>
> So my basic question is, if anyone has been able to install the component
> on Karaf?
>
> It may be, that the entire issue is much more simple when getting the
> right spring-data dependency in place. However, I did not find the
> appropriate.
>
> Please see the errors that I've been getting:
>
> Error executing command: Could not start bundle
> mvn:org.apache-extras.camel-extra/camel-spring-neo4j/2.11-SNAPSHOT in
> feature(s) camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in
> bundle org.apache-extras.camel-extra.camel-spring-neo4j [54]: Unable to
> resolve 54.0: missing requirement [54.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.apache.camel)(version>=2.11.0)(!(version>=2.12.0)))
> FIX: <feature version='${camel-version}'>camel</feature>
>
> Error executing command: Could not start bundle
> mvn:org.apache-extras.camel-extra/camel-spring-neo4j/2.11-SNAPSHOT in
> feature(s) camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in
> bundle org.apache-extras.camel-extra.camel-spring-neo4j [79]: Unable to
> resolve 79.0: missing requirement [79.0] osgi.wiring.package;
> (osgi.wiring.package=org.neo4j.graphdb)
> ATTEMPTED FIX:
> <bundle>wrap:mvn:org.neo4j/neo4j-kernel/${neo4j-version}</bundle>
>
> Error executing command: Could not start bundle
> mvn:org.apache-extras.camel-extra/camel-spring-neo4j/2.11-SNAPSHOT in
> feature(s) camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in
> bundle org.apache-extras.camel-extra.camel-spring-neo4j [105]: Unable to
> resolve 105.0: missing requirement [105.0] osgi.wiring.package;
> (&(osgi.wiring.package=org.springframework.data.neo4j.core)(version>=2.2.0)(!(version>=3.0.0)))
> ATTEMPTED FIX:
> <bundle>mvn:org.springframework.data/spring-data-neo4j/${spring-neo4j-version}</bundle>
>
> Error executing command: Could not start bundle
> mvn:org.springframework.data/spring-data-neo4j/2.2.1.RELEASE in feature(s)
> camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in bundle
> org.springframework.data.neo4j [131]: Unable to resolve 131.0: missing
> requirement [131.0] osgi.wiring.package;
> (&(osgi.wiring.package=com.mysema.query.annotations)(version>=0.0.0))
> ATTEMPTED FIX:
> <bundle>wrap:mvn:com.mysema.querydsl/querydsl-apt/${querydsl-version}</bundle>
>
> Error executing command: Could not start bundle
> wrap:mvn:com.mysema.querydsl/querydsl-apt/2.9.0 in feature(s)
> camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in bundle
> com.mysema.querydsl.apt [158]: Unable to resolve 158.0: missing requirement
> [158.0] osgi.wiring.package;
> (&(osgi.wiring.package=com.google.common.base)(version>=11.0.2))
> ATTEMPTED FIX:
> <bundle>wrap:mvn:com.google.guava/guava/${guava-version}</bundle>
>
> So I ended up having the following feature configuration:
>
>     <feature name='camel-spring-neo4j' version='${project.version}'
> resolver='(obr)' start-level='50'>
>       <feature version='${camel-version}'>camel</feature>
>       <bundle>wrap:mvn:org.neo4j/neo4j-kernel/${neo4j-version}</bundle>
>       <bundle>wrap:mvn:com.google.guava/guava/${guava-version}</bundle>
>
> <bundle>wrap:mvn:com.mysema.querydsl/querydsl-apt/${querydsl-version}</bundle>
>
> <bundle>mvn:org.springframework.data/spring-data-neo4j/${spring-neo4j-version}</bundle>
>
> <bundle>mvn:org.apache-extras.camel-extra/camel-spring-neo4j/${project.version}</bundle>
>     </feature>
>
> However, I'm still getting the following error:
>
> Error executing command: Could not start bundle
> wrap:mvn:com.mysema.querydsl/querydsl-core/2.9.0 in feature(s)
> camel-spring-neo4j-2.11-SNAPSHOT: Unresolved constraint in bundle
> com.mysema.querydsl.core [186]: Unable to resolve 186.0: missing
> requirement [186.0] osgi.wiring.package;
> (&(osgi.wiring.package=com.google.common.base)(version>=11.0.2))
>
> Hope that someone can support me with this issue.
>
> Many thanks and kind regards,
>
> Christoph

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message