camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Babak Vahdat <babak.vah...@swissonline.ch>
Subject Re: Our builds looks really bad...
Date Mon, 27 May 2013 05:46:38 GMT
Hi

FYI: The ticket being raised below has been already fixed.

Babak


Babak Vahdat wrote
> Hi
> 
> I raised a ticket regarding this @ INFRA:
> 
>  https://issues.apache.org/jira/browse/INFRA-6207
> 
> Babak
> Babak Vahdat wrote
>> Yeah seems to be a known JDK 6 bug, following two very similar reported
>> issues (found : XYZ   required: XYZ):
>> 
>> http://stackoverflow.com/questions/8417633/mvn-install-fails-due-to-incompatible-types
>> https://issues.jboss.org/browse/JBTM-997
>> 
>> Just wonder if in the last days/weeks INFRA has done some "JDK 6 latest"
>> upgrades on CI-Servers.
>> 
>> Babak
>> 
>> Babak Vahdat wrote
>>> Hi
>>> 
>>> I guess it was already picking Maven 3.0.4 correctly:
>>> 
>>> [camel-trunk] $ /home/hudson/tools/java/latest1.6/bin/java -da -dsa
>>> -XX:MaxPermSize=512m -Xmx1200m -cp
>>> /home/jenkins/jenkins-slave/maven3-agent.jar:/home/hudson/tools/maven/apache-maven-3.0.4/boot/plexus-classworlds-2.4.jar
>>> org.jvnet.hudson.maven3.agent.Maven3Main
>>> /home/hudson/tools/maven/apache-maven-3.0.4
>>> /home/jenkins/jenkins-slave/slave.jar
>>> /home/jenkins/jenkins-slave/maven3-interceptor.jar 46131
>>> 
>>> As I can see here from the build I kicked yesterday:
>>> 
>>> https://builds.apache.org/job/Camel.trunk.notest/1853/consoleText
>>> 
>>> I kicked another build today after Claus change ("Maven 3 (latest)" ==>
>>> "Maven 3.0.4"). No idea why this but the same wired problem seems still
>>> a compilation error at the camel-core module:
>>> 
>>> [ERROR] COMPILATION ERROR : 
>>> [INFO] -------------------------------------------------------------
>>> [ERROR]
>>> /home/jenkins/jenkins-slave/workspace/Camel.trunk.notest/camel-trunk/camel-core/src/main/java/org/apache/camel/language/XPath.java:[44,5]
>>> incompatible types
>>> found   : org.apache.camel.language.NamespacePrefix
>>> required: org.apache.camel.language.NamespacePrefix
>>> [ERROR]
>>> /home/jenkins/jenkins-slave/workspace/Camel.trunk.notest/camel-trunk/camel-core/src/main/java/org/apache/camel/language/XPath.java:[45,5]
>>> incompatible types
>>> found   : org.apache.camel.language.NamespacePrefix
>>> required: org.apache.camel.language.NamespacePrefix
>>> [INFO] 2 errors 
>>> 
>>> Babak
>>> Claus Ibsen-2 wrote
>>>> At first peak it looks as if Jenkins has trouble picking latest apache
>>>> maven, so it goes for 2.2.1.
>>>> I tried to change the no-test project to use maven 3.0.4 instead of
>>>> maven (latest).
>>>> 
>>>> 
>>>> 
>>>> On Sat, Apr 27, 2013 at 6:13 PM, Christian Müller
>>>> &lt;

>>>> christian.mueller@

>>>> &gt; wrote:
>>>>> Let's focus on blue bubbles in the next days before we add new
>>>>> features/improvements. Our build looks really bad at present...
>>>>>
>>>>> Thanks in advance,
>>>>> Christian
>>>> 
>>>> 
>>>> 
>>>> -- 
>>>> Claus Ibsen
>>>> -----------------
>>>> Red Hat, Inc.
>>>> FuseSource is now part of Red Hat
>>>> Email: 

>>>> cibsen@

>>>> Web: http://fusesource.com
>>>> Twitter: davsclaus
>>>> Blog: http://davsclaus.com
>>>> Author of Camel in Action: http://www.manning.com/ibsen





--
View this message in context: http://camel.465427.n5.nabble.com/Our-builds-looks-really-bad-tp5731673p5733236.html
Sent from the Camel Development mailing list archive at Nabble.com.

Mime
View raw message