camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: [VOTE] Release Apache Camel 2.9.7
Date Fri, 26 Apr 2013 20:31:01 GMT
+1

The PDF looks good.
The Camel in Action source code (rev. 337) works with Camel 2.9.7.
I only got an exception by installing camel-spring-ws in Karaf 2.2.10:

cmueller$ ./karaf clean
        __ __                  ____
       / //_/____ __________ _/ __/
      / ,<  / __ `/ ___/ __ `/ /_
     / /| |/ /_/ / /  / /_/ / __/
    /_/ |_|\__,_/_/   \__,_/_/

  Apache Karaf (2.2.10)

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'osgi:shutdown' or 'logout' to shutdown Karaf.

karaf@root> chooseurl camel 2.9.7
adding feature url
mvn:org.apache.camel.karaf/apache-camel/2.9.7/xml/features
karaf@root> feature:install camel-spring-ws
Error executing command: Could not start bundle mvn:
org.springframework.ws/spring-ws-core/2.0.3.RELEASE in feature(s)
camel-spring-ws-2.9.7: Uses constraint violation. Unable to resolve module
org.springframework.ws [103.0] because it is exposed to package
'javax.activation' from modules org.apache.felix.framework [0] and
org.apache.servicemix.specs.activation-api-1.1 [64.0] via two dependency
chains.

Chain 1:
  org.springframework.ws [103.0]
    import: (&(package=javax.activation)(version>=0.0.0))
     |
    export: package=javax.activation
  org.apache.felix.framework [0]

Chain 2:
  org.springframework.ws [103.0]
    import:
(&(package=org.springframework.oxm.mime)(version>=3.0.6)(!(version>=4.0.0)))
     |
    export: package=org.springframework.oxm.mime; uses:=javax.activation
  org.springframework.oxm [100.0]
    import: (&(package=javax.activation)(version>=0.0.0))
     |
    export: package=javax.activation
  org.apache.servicemix.specs.activation-api-1.1 [64.0]

Best,
Christian


On Wed, Apr 24, 2013 at 11:32 PM, Christian Müller <
christian.mueller@gmail.com> wrote:

> After 6 weeks of development, we have a new patch release candidate
> apache-camel-2.9.7 ready. It comes with 14 issues resolved [1].
> This will be the last planned Camel 2.9.x release. We will discontinue the
> support for the camel-2.9.x branch afterwards.
>
> Please find the staging repo here:
> https://repository.apache.org/content/repositories/orgapachecamel-134/
>
> The tarballs are here
>
> https://repository.apache.org/content/repositories/orgapachecamel-134/org/apache/camel/apache-camel/2.9.7/
>
> Tag:
> http://svn.apache.org/repos/asf/camel/tags/camel-2.9.7/
>
> Please review, help out with testing and vote to approve this release
> binary. Please mention what you tested to prevent duplicate work. Your vote
> counts!
>
> [ ] +1 Release the binary as Apache Camel 2.9.7
> [ ] -1 Veto the release (provide specific comments)
> Vote is open for at least 72 hours.
>
> Thanks in advance,
> Christian
>
> [1]
> https://issues.apache.org/jira/issues/?jql=project%20%3D%20CAMEL%20AND%20fixVersion%20%3D%20%222.9.7%22
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message