camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Müller <christian.muel...@gmail.com>
Subject Re: [VOTE] Release Apache Camel 2.9.6
Date Thu, 07 Mar 2013 05:10:26 GMT
+0

The ASC, MD5 and SHA1 files looks good (checked some of them).

I got one failure by building the Camel in Action source code (revision
337) with this version:
- chapter10-client: camelinaction.RiderAutoPartsCallbackTest.testCallback()

By installing camel-core 2.9.6 in Apache Karaf 2.2.5 I (as mentioned at
[1]) got the following exception:

Christian-Muellers-MacBook-Pro:bin cmueller$ ./karaf clean
        __ __                  ____
       / //_/____ __________ _/ __/
      / ,<  / __ `/ ___/ __ `/ /_
     / /| |/ /_/ / /  / /_/ / __/
    /_/ |_|\__,_/_/   \__,_/_/

  Apache Karaf (2.2.5)

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or 'osgi:shutdown' to shutdown Karaf.

karaf@root> features:addurl
mvn:org.apache.camel.karaf/apache-camel/2.9.6/xml/features
karaf@root> feature:install camel-core
Error executing command: Could not start bundle
mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.6 in feature(s)
camel-core-2.9.6: Unresolved constraint in bundle
org.apache.camel.karaf.camel-karaf-commands [64]: Unable to resolve 64.0:
missing requirement [64.0] package;
(&(package=jline.console.completer)(version>=2.6.0)(!(version>=3.0.0)))


But it works in Karaf 2.2.10:
Christian-Muellers-MacBook-Pro:bin cmueller$ ./karaf clean
        __ __                  ____
       / //_/____ __________ _/ __/
      / ,<  / __ `/ ___/ __ `/ /_
     / /| |/ /_/ / /  / /_/ / __/
    /_/ |_|\__,_/_/   \__,_/_/

  Apache Karaf (2.2.10)

Hit '<tab>' for a list of available commands
and '[cmd] --help' for help on a specific command.
Hit '<ctrl-d>' or type 'osgi:shutdown' or 'logout' to shutdown Karaf.

karaf@root> features:chooseurl camel 2.9.6
adding feature url
mvn:org.apache.camel.karaf/apache-camel/2.9.6/xml/features
karaf@root> feature:install camel-core

We should update [1] that Camel 2.9.6 requires Apache Karaf 2.2.10 (I
didn't tested whether it works also with Karaf 2.2.6+).
I didn't test to install the other Camel components in Karaf.

[1] http://camel.apache.org/karaf.html

Best,
Christian



On Tue, Mar 5, 2013 at 5:51 AM, Hadrian Zbarcea <hzbarcea@gmail.com> wrote:

> We have a new patch release candidate apache-camel-2.9.6 ready. It comes
> with approximately 63 issues resolved: improvements and bug fixes [1].
>
> Please find the staging repo here:
> https://repository.apache.org/**content/repositories/**orgapachecamel-330/<https://repository.apache.org/content/repositories/orgapachecamel-330/>
>
> The tarballs are here
> https://repository.apache.org/**content/repositories/**
> orgapachecamel-330/org/apache/**camel/apache-camel/2.9.6/<https://repository.apache.org/content/repositories/orgapachecamel-330/org/apache/camel/apache-camel/2.9.6/>
>
> Tag:
> http://svn.apache.org/repos/**asf/camel/tags/camel-2.9.6/<http://svn.apache.org/repos/asf/camel/tags/camel-2.9.6/>
>
> Please review, help out with testing and vote to approve this release
> binary. Your vote counts!
>
> [ ] +1 Release the binary as Apache Camel 2.9.6
> [ ] -1 Veto the release (provide specific comments)
> Vote is open for at least 72 hours.
>
> Here's my +1.
> Hadrian
>
> [1]
> https://issues.apache.org/**jira/secure/ReleaseNote.jspa?**
> projectId=12311211&version=**12323592<https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311211&version=12323592>
>
> --
> Hadrian Zbarcea
> Principal Software Architect
> Talend, Inc
> http://coders.talend.com/
> http://camelbot.blogspot.com/
>



--

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message