camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raul Kripalani <r...@evosent.com>
Subject Re: [HEADS-UP] Possible issue with neo4j
Date Wed, 27 Mar 2013 16:42:56 GMT
On Wed, Mar 27, 2013 at 3:36 PM, Christian Ohr <christian.ohr@gmail.com>wrote:

> Things can be subtle, though, e.g. MongoDB is also (A)GPL, but the
> mongo-java-driver that camel-mongodb depends upon is ASL2 (
> https://github.com/mongodb/mongo-java-driver/blob/master/LICENSE.txt)....
>

I too had some doubts at first, but the case is substantially different.
The MongoDB Java driver doesn't have any dependencies with other libraries
(see pom.xml [1]). Therefore no linkage exists. Just with TestNG – which is
ASL.

In other words, this driver is 100% self-encapsulating, and it's isolated
from MongoDB components or any other incompatible libraries.

[1] https://github.com/mongodb/mongo-java-driver/blob/master/pom.xml

Regards,

*Raúl Kripalani*
Enterprise Architect, Open Source Integration specialist, Program
Manager | Apache
Camel Committer
http://about.me/raulkripalani | http://www.linkedin.com/in/raulkripalani
http://blog.raulkr.net | twitter: @raulvk

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message