camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Babak Vahdat <babak.vah...@swissonline.ch>
Subject Re: [DISCUSS] - Moving towards Camel 2.11 release
Date Sun, 20 Jan 2013 19:56:22 GMT
Hi

actually the trunk is currently not that much bad and again back to the
stable. The latest "Camel.trunk.fulltest" made it with one single failure:

https://builds.apache.org/job/Camel.trunk.fulltest/1197/

and "Camel.trunk.fulltest.java7" did it with 8 failures but only by
camel-sjms which was mostly because of "port number already in use".

https://builds.apache.org/job/Camel.trunk.fulltest.java7/461/

Babak


Christian Mueller wrote
> The last successful build on Jenkins for Camel trunk full-test was on Dec.
> 13th - more than one month ago...
> 
> :-(
> 
> Best,
> Christian
> 
> On Thu, Jan 17, 2013 at 6:28 PM, Hadrian Zbarcea &lt;

> hzbarcea@

> &gt; wrote:
> 
>> I started dry run builds in preparation of release. There are a bunch of
>> failures on my machine, especially JMS. Not sure what the cause yet,
>> looking into it.
>>
>> Cheers,
>> Hadrian
>>
>>
>> On 01/11/2013 06:07 PM, Christian Müller wrote:
>>
>>> Find my comments inline.
>>>
>>> Best,
>>> Christian
>>>
>>> On Mon, Jan 7, 2013 at 2:31 PM, Claus Ibsen &lt;

> claus.ibsen@

> &gt;
>>> wrote:
>>>
>>>  Hi
>>>>
>>>> I think we should start closing down on the upcoming Camel 2.11
>>>> release.
>>>>
>>>>  +1
>>>
>>>
>>>> There is a few important tickets which IMHO needs to be resolved
>>>> before we are in shape.
>>>>
>>>>  Two of my tickets are target for 2.11.0 and I will fix they in the
>>>> next
>>> days.
>>>
>>>
>>>> 1)
>>>> New set of OSGi bundles from the SMX team.
>>>> There is some new Camel components and JAR upgrades that requires a
>>>> new set of OSGi bundles.
>>>>
>>>> 2)
>>>> Upgrade to Scala 2.10
>>>> The 3rd party component which we depend on in camel-web have been
>>>> upgraded to Scala 2.10 (eg scalate).
>>>> So we ought to be in a position to upgrade camel-scala to Scala 2.10.
>>>> What is missing is an OSGi bundle for Scala 2.10. (eg see #1)
>>>>
>>>> 3)
>>>> Apache Karaf 2.3.1 release
>>>>
>>>> We need Karaf 2.3.x to support Spring 3.1 out of the box. Currently it
>>>> has an issue causing both Spring 3.0 and 3.1
>>>> to be installed if you install Camel in Karaf.
>>>>
>>>> There is a post on Karaf @dev about this, and the Karaf team seems
>>>> willingly to fix this. And hopefully cut a new release
>>>> with this fix.
>>>>
>>>> 4)
>>>> We should revisit the open ticket, and get stuff either fixed or
>>>> postponed to either Camel 2.12 or 2.11.1.
>>>>
>>>>  Two of my tickets are target for 2.11.0 and I will fix they in the
>>>> next
>>> days.
>>>
>>>
>>>> 5)
>>>> Look at CI and fix any test issues and other build issues.
>>>> I think there is a camel-jclouds failure.
>>>>
>>>> 6)
>>>> If there is stuff you want to be included in Camel 2.11, then let us
>>>> know.
>>>>
>>>>
>>>>
>>>> --
>>>> Claus Ibsen
>>>> -----------------
>>>> Red Hat, Inc.
>>>> FuseSource is now part of Red Hat
>>>> Email: 

> cibsen@

>>>> Web: http://fusesource.com
>>>> Twitter: davsclaus
>>>> Blog: http://davsclaus.com
>>>> Author of Camel in Action: http://www.manning.com/ibsen
>>>>
>>>>
>>>
>>>
>>> --
>>>
>>>
> 
> 
> --





--
View this message in context: http://camel.465427.n5.nabble.com/DISCUSS-Moving-towards-Camel-2-11-release-tp5725088p5725849.html
Sent from the Camel Development mailing list archive at Nabble.com.

Mime
View raw message