camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Builds on Jenkins
Date Mon, 29 Oct 2012 09:18:08 GMT
Hi

I suspect its OSGi framework 4.2 -> 4.3 that is not backwards compatible.
Have not checked it, but seems like the code changes in
camel-core-osgi I assume was needed during the upgrade.
And if so, it may be that we are not binary backwards compatible.

As a temporary workaround we could downgrade to 4.2. But we would need
to come up with a solution so we can upgrade Camel.
As OSGi R5 is out, and we are only on 4.2.


On Sun, Oct 28, 2012 at 11:05 AM, Babak Vahdat
<babak.vahdat@swissonline.ch> wrote:
> Hi
>
> Currently all the OSGi integration tests I tried fail as well with the
> same root cause and as we disable these tests on the CI-Servers we don't
> spot the problem there.
>
> I digged pretty long into it but couldn't find the problem. Needs some
> OSGi experts to look into it.
>
> There was also a new test by camel-gson on the trunk failing continuously
> by some profiles which I've already fixed.
>
> Following a sample itest failing:
>
> ~/dev/workspace/camel/tests/camel-itest-osgi>mvn test -Dtest=FileRouteTest
> Š
> Š
> java.lang.Exception: Could not start bundle
> mvn:org.apache.camel/camel-core/2.11-SNAPSHOT in feature(s)
> camel-core-2.11-SNAPSHOT: Activator start error in bundle
> org.apache.camel.camel-core [67].
>         at
> org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(Feat
> uresServiceImpl.java:356)[21:org.apache.karaf.features.core:2.2.9]
>         at
> org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServic
> eImpl.java:988)[21:org.apache.karaf.features.core:2.2.9]
> Caused by: org.osgi.framework.BundleException: Activator start error in
> bundle org.apache.camel.camel-core [67].
>         at
> org.apache.felix.framework.Felix.activateBundle(Felix.java:1951)[org.apache
> .felix.framework-3.2.2.jar:]
>         at
> org.apache.felix.framework.Felix.startBundle(Felix.java:1822)[org.apache.fe
> lix.framework-3.2.2.jar:]
>         at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:927)[org.apache
> .felix.framework-3.2.2.jar:]
>         at
> org.apache.felix.framework.BundleImpl.start(BundleImpl.java:914)[org.apache
> .felix.framework-3.2.2.jar:]
>         at
> org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(Feat
> uresServiceImpl.java:353)[21:org.apache.karaf.features.core:2.2.9]
>         ... 1 more
> Caused by: java.lang.NoClassDefFoundError:
> org/osgi/framework/BundleActivator
>         at java.lang.ClassLoader.defineClass1(Native Method)[:1.6.0_32]
>         at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)[:1.6.0_32]
>         at java.lang.ClassLoader.defineClass(ClassLoader.java:615)[:1.6.0_32]
>         at
> org.apache.felix.framework.ModuleImpl$ModuleClassLoader.findClass(ModuleImp
> l.java:1947)
>         at
> org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(Modul
> eImpl.java:752)
>         at org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:72)
>         at
> org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImp
> l.java:1807)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)[:1.6.0_32]
>         at
> org.apache.felix.framework.ModuleImpl.getClassByDelegation(ModuleImpl.java:
> 670)
>         at org.apache.felix.framework.Felix.createBundleActivator(Felix.java:3808)
>         at org.apache.felix.framework.Felix.activateBundle(Felix.java:1899)
>         ... 5 more
> Caused by: java.lang.ClassNotFoundException:
> org.osgi.framework.BundleActivator not found by
> org.apache.camel.camel-core [67]
>         at
> org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(Modul
> eImpl.java:812)[org.apache.felix.framework-3.2.2.jar:]
>         at
> org.apache.felix.framework.ModuleImpl.access$400(ModuleImpl.java:72)[org.ap
> ache.felix.framework-3.2.2.jar:]
>         at
> org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImp
> l.java:1807)[org.apache.felix.framework-3.2.2.jar:]
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)[:1.6.0_32]
>         ... 16 more
> Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 5.687 sec
> <<< FAILURE!
>
> Babak
>
>
> Am 27.10.12 23:07 schrieb "Christian Müller" unter
> <christian.mueller@gmail.com>:
>
>>At present, many of our builds at Jenkins fail [0] and it looks like they
>>are not stable. Some of the build are failing since three or more weeks.
>>This is really bad.
>>Let's reserve some time to fix this and bring the Camel builds back to
>>stable. Assign one of the issues to yourself and work on it.
>>
>>[0] https://builds.apache.org/view/A-F/view/Camel/
>>[1] https://issues.apache.org/jira/browse/CAMEL-5749
>>[2] https://issues.apache.org/jira/browse/CAMEL-5750
>>[3] https://issues.apache.org/jira/browse/CAMEL-5751
>>[4] https://issues.apache.org/jira/browse/CAMEL-5752
>>[5] https://issues.apache.org/jira/browse/CAMEL-5753
>>
>>Thanks in advance,
>>Christian
>>
>>--
>
>



-- 
Claus Ibsen
-----------------
Red Hat, Inc.
FuseSource is now part of Red Hat
Email: cibsen@redhat.com
Web: http://fusesource.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message