camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Babak Vahdat <babak.vah...@swissonline.ch>
Subject Re: About Apache Mina2 dependency being upgraded to 2.0.5
Date Fri, 28 Sep 2012 06:40:30 GMT


Am 28.09.12 07:57 schrieb "Claus Ibsen" unter <claus.ibsen@gmail.com>:

>Hi Babak
>
>Well spotted again. The camel-mina2 tests passed fine. So I guess the
>issue is more related to 3rd party frameworks not compiled against
>Mina 2.0.5, but using the older API in 2.0.x. such as the FTP
>libraries and whatnot.

Like the newest sshd version being still dependent on Mina2.0.4

http://central.maven.org/maven2/org/apache/sshd/sshd/0.7.0/sshd-0.7.0.pom

Also by camel-ftp unit-tests I realized that we still make use of an older
version of Mina 2.0.0, which I already upgraded to 2.0.4 and verified that
they all do pass.

>
>But still its a critical issue for people as they cannot easily
>upgrade Camel not can they upgrade Mina to 2.0.5.
>
>I have logged a ticket at Mina JIRA
>https://issues.apache.org/jira/browse/DIRMINA-908
>
>As Mina2 (by sshd) is also used by Karaf I think, we should downgrade to
>2.0.4.

I'll take care of that.

>We can then keep an eye with that ticket from Mina and hear what they
>have to say. Maybe they would consider cutting a new release with the
>API fixed.
>
>
>
>On Thu, Sep 27, 2012 at 11:31 PM, Babak Vahdat
><babak.vahdat@swissonline.ch> wrote:
>> Hi,
>>
>> Today we upgraded Apache Mina2 dependency from 2.0.4 to 2.0.5 which is
>>NOT
>> binary compatible anymore because of the following revision (the
>> IoAcceptor.bind() method with one argument has been replaced with
>>varargs
>> variant causing NoSuchMethodError @ runtime):
>>
>> http://svn.apache.org/viewvc?view=revision&revision=1374994
>>
>> The tests on CI-Server afterwards show failures by:
>>
>> camel-jsch (has test scope dependency to mina2)
>> camel-ssh (has compile scope dependency to mina2)
>>
>> By camel-jsch I downgraded the test dependency back to 2.0.4 version
>>which
>> more or less we could live with it (as it's test scope). And then
>>afterwards
>> I realized the failed tests by camel-ssh as well which I think because
>>of
>> the compile scope dependency, a downgrade would not make much sense.
>>
>> I think we should better downgrade back to 2.0.4 until this problem is
>> resolved.
>>
>> Any thoughts?
>>
>> Babak
>>
>>
>>
>> --
>> View this message in context:
>>http://camel.465427.n5.nabble.com/About-Apache-Mina2-dependency-being-upg
>>raded-to-2-0-5-tp5720169.html
>> Sent from the Camel Development mailing list archive at Nabble.com.
>
>
>
>-- 
>Claus Ibsen
>-----------------
>Red Hat, Inc.
>FuseSource is now part of Red Hat
>Email: cibsen@redhat.com
>Web: http://fusesource.com
>Twitter: davsclaus
>Blog: http://davsclaus.com
>Author of Camel in Action: http://www.manning.com/ibsen



Mime
View raw message