camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Babak Vahdat <>
Subject About Apache Mina2 dependency being upgraded to 2.0.5
Date Thu, 27 Sep 2012 21:31:44 GMT

Today we upgraded Apache Mina2 dependency from 2.0.4 to 2.0.5 which is NOT
binary compatible anymore because of the following revision (the
IoAcceptor.bind() method with one argument has been replaced with varargs
variant causing NoSuchMethodError @ runtime):

The tests on CI-Server afterwards show failures by:

camel-jsch (has test scope dependency to mina2)
camel-ssh (has compile scope dependency to mina2)

By camel-jsch I downgraded the test dependency back to 2.0.4 version which
more or less we could live with it (as it's test scope). And then afterwards
I realized the failed tests by camel-ssh as well which I think because of
the compile scope dependency, a downgrade would not make much sense.

I think we should better downgrade back to 2.0.4 until this problem is

Any thoughts?


View this message in context:
Sent from the Camel Development mailing list archive at

View raw message