camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Invalid JAR for axiom 1.2.13 causes problem for OSGi users
Date Mon, 20 Aug 2012 18:33:21 GMT

It *MAY* have something to do with a co-existence with the Neethi version that CXF requires,
but not really sure.   The latest version of Neethi would definitely require Axiom 1.2.13
for SOME of it's operations that would use Axiom, but I'm not really sure of the details.
  Thus, I think the reasoning was CXF requires latest Neethi which requires latest Axiom if
using Axiom, thus, grab latest Axiom.

That all said, I know the Axiom stuff in Neethi is optional and CXF certainly wouldn't be
using any of those code paths.   If you want to test things out, try the old axiom and then
install the latest camel-cxf stuff and see if that still looks OK.

Dan



On Aug 20, 2012, at 7:14 AM, Claus Ibsen <claus.ibsen@gmail.com> wrote:

> Hi
> 
> I was looking into OSGi failures on Camel trunk, and logged a ticket
> https://issues.apache.org/jira/browse/CAMEL-5522
> 
> We have 3 components that do not work on Karaf 2.2.9.
> 
> camel-atom
> camel-rss
> camel-hbase
> 
> The latter camel-hbase is because we need an OSGi wrapped library of
> Hadoop HBase itself.
> Do we have a JIRA ticket for that?
> 
> The former 2 errors is due an invalid JAR in central repo for
> http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22org.apache.ws.commons.axiom%22%20AND%20a%3A%22axiom-impl%22
> 
> 1.2.13 has a problem causing Karaf to not read the JAR
> karaf@root> features:install camel-atom
> Error executing command: Manifest not present in the first entry of
> the zip mvn:org.apache.ws.commons.axiom/axiom-impl/1.2.13
> 
> But using 1.2.12 works fine
> karaf@root> features:install camel-atom
> Refreshing bundles org.springframework.context.support (57)
> 
> 
> I wonder if anyone can remember the reason for the 1.2.13 upgrade? Was
> it just because of hey there is a newer release. Or was there some bug
> fixes we needed?
> 
> I am asking as we may have to downgrade to last known working which is 1.2.12.
> 
> In the latest release of Apache Camel 2.10.0, we use 1.2.10 as the axiom version
> http://search.maven.org/remotecontent?filepath=org/apache/camel/karaf/apache-camel/2.10.0/apache-camel-2.10.0-features.xml
> 
> What should we do? Downgrade to 1.2.12 or 1.2.10?
> Can anyone remember why we need 1.2.13 ?
> 
> 
> -- 
> Claus Ibsen
> -----------------
> FuseSource
> Email: cibsen@fusesource.com
> Web: http://fusesource.com
> Twitter: davsclaus, fusenews
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen

-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message