camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject [DISCUSS] - Camel 2.11 set with Spring 3.1 out of the box
Date Tue, 10 Jul 2012 07:00:33 GMT
Hi

I wonder if we should upgrade Camel 2.11 to use Spring 3.1.x as
default out of the box.
Camel 2.11 should still be compatible with Spring 3.0.x.

We just need to ensure the OSGi import range for camel-spring is [3,4)
etc. I think its already that.

In the old days with Spring 2.x we had some itests that ran a sanity
test with Spring 2.0, when Spring 2.5 was the default out of the box.
We could do the same for 3.0, when 3.1 is the default out of the box.

Any thoughts?



-- 
Claus Ibsen
-----------------
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus, fusenews
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen

Mime
View raw message