camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Claus Ibsen <claus.ib...@gmail.com>
Subject Re: Problem with Camel commands and and Karaf 3
Date Mon, 30 Apr 2012 09:53:45 GMT
On Mon, Apr 30, 2012 at 11:18 AM, Christian Schneider
<chris@die-schneider.net> wrote:
> Hi all,
>
> we provide some camel commands for karaf in our distro. With Karaf 3 there
> are some incompatible changes in the command API. So currently camel does
> not install on Karaf 3.
> I will try to work out a solution for the commands to ideally make them
> compatible.
>
> For the moment though I propose we remove the command bundle from the
> camel-core feature and move it to a command that can be installed
> spearately. So Camel can already be used and tested on Karaf 3. Is this ok?
> If yes for what versions of camel should I do this change? I think 2.9.x and
> trunk could make sense.
>

What is the compatibly issue?


> Christian
>
> --
> Christian Schneider
> http://www.liquid-reality.de
>
> Open Source Architect
> Talend Application Integration Division http://www.talend.com
>



-- 
Claus Ibsen
-----------------
CamelOne 2012 Conference, May 15-16, 2012: http://camelone.com
FuseSource
Email: cibsen@fusesource.com
Web: http://fusesource.com
Twitter: davsclaus, fusenews
Blog: http://davsclaus.blogspot.com/
Author of Camel in Action: http://www.manning.com/ibsen/

Mime
View raw message