camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Karlsen <davidkarl...@gmail.com>
Subject Re: [PROPOSAL] - camel-test - @deprecate JUnit 3.x API
Date Wed, 28 Dec 2011 21:52:25 GMT
+1
Den 28. des. 2011 18:54 skrev "Christian Schneider" <chris@die-schneider.net>
følgende:

> +1 for deprecation and removing in 3.0.0
>
> Christian
>
> Am 28.12.2011 16:08, schrieb Claus Ibsen:
>
>> Hi
>>
>> The camel-test component supports currently both JUnit 3.x and 4.x,
>> each in separate package.
>> Supporting both requires us to have a fair amount of duplicated code,
>> one for 3.x and another for 4.x.
>>
>> I suggest to @deprecated the JUnit 3.x part of the camel-test component.
>> Then we can remove support for 3.x in Camel 3.0.
>>
>> Any thoughts?
>>
>>
>>
>
> --
> Christian Schneider
> http://www.liquid-reality.de
>
> Open Source Architect
> Talend Application Integration Division http://www.talend.com
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message