camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aleksey Sushko (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CAMEL-4658) Camel 2.9.0 SNAPSHOT not start on OSGI apache karaf
Date Thu, 10 Nov 2011 13:51:51 GMT

     [ https://issues.apache.org/jira/browse/CAMEL-4658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Aleksey Sushko updated CAMEL-4658:
----------------------------------

    Description: 
Compiling my project is done using maven pluggins
maven-dependency-plugin and features-maven-plugin.
First unpack apache-karaf-2.2.3.zip.
The second component uses mvn:org.apache.camel.karaf/apache-camel/${ camel-version }/xml/features

karaf-version = 2.2.3
camel-version = 2.9.0-SNAPSHOT (build 2011-11-10)

Establish the following set of components
{code}
<feature version='${karaf-version}'>ssh</feature>
<feature version='${karaf-version}'>config</feature>
<feature version='${karaf-version}'>webconsole</feature>
<feature version='${karaf-version}'>wrapper</feature>

<feature version='${camel-version}'>camel-blueprint</feature>
<feature version='${camel-version}'>camel-ftp</feature>
<feature version='${camel-version}'>camel-http</feature>
<feature version='${camel-version}'>camel-http4</feature>
<feature version='${camel-version}'>camel-quartz</feature>
{code}
After starting karaf error log ${karaf.data}/log/karag.log
{code}
2011-11-10 16:19:51,128 | ERROR | Thread-6                                               
           | FeaturesServiceImpl              | s.internal.Features
ServiceImpl$1  977 | 11 - org.apache.karaf.features.core - 2.2.3 | Error installing boot features
java.lang.Exception: Could not start bundle mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.0-SNAPSHOT
in feature(s) camel-core-2.9.0-SNAPSHOT: Unresolve
d constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve
95.0: missing requirement [95.0] package; (&(package=org.apache.fe
lix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
        at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:353)[11:org.apache.karaf.features.core:2.2.3]
        at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:975)[11:org.apache.karaf.features.core:2.2.3]
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.karaf.camel-karaf-commands
[95]: Unable to resolve 95.0: miss
ing requirement [95.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
{code}
We must add a dependency on a component in a file features.xml

Camel 2.8.1 and 2.7.0 to work correctly.

  was:
Compiling my project is done using maven pluggins
maven-dependency-plugin and features-maven-plugin.
First unpack apache-karaf-2.2.3.zip.
The second component uses mvn:org.apache.camel.karaf/apache-camel/${ camel-version }/xml/features

karaf-version = 2.2.3
camel-version = 2.9.0-SNAPSHOR (build 2011-11-10)

Establish the following set of components
{code}
<feature version='${karaf-version}'>ssh</feature>
<feature version='${karaf-version}'>config</feature>
<feature version='${karaf-version}'>webconsole</feature>
<feature version='${karaf-version}'>wrapper</feature>

<feature version='${camel-version}'>camel-blueprint</feature>
<feature version='${camel-version}'>camel-ftp</feature>
<feature version='${camel-version}'>camel-http</feature>
<feature version='${camel-version}'>camel-http4</feature>
<feature version='${camel-version}'>camel-quartz</feature>
{code}
After starting karaf error log ${karaf.data}/log/karag.log
{code}
2011-11-10 16:19:51,128 | ERROR | Thread-6                                               
           | FeaturesServiceImpl              | s.internal.Features
ServiceImpl$1  977 | 11 - org.apache.karaf.features.core - 2.2.3 | Error installing boot features
java.lang.Exception: Could not start bundle mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.0-SNAPSHOT
in feature(s) camel-core-2.9.0-SNAPSHOT: Unresolve
d constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve
95.0: missing requirement [95.0] package; (&(package=org.apache.fe
lix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
        at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:353)[11:org.apache.karaf.features.core:2.2.3]
        at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:975)[11:org.apache.karaf.features.core:2.2.3]
Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.karaf.camel-karaf-commands
[95]: Unable to resolve 95.0: miss
ing requirement [95.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
{code}
We must add a dependency on a component in a file features.xml

Camel 2.8.1 and 2.7.0 to work correctly.

    
> Camel 2.9.0 SNAPSHOT not start on OSGI apache karaf
> ---------------------------------------------------
>
>                 Key: CAMEL-4658
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4658
>             Project: Camel
>          Issue Type: Bug
>            Reporter: Aleksey Sushko
>
> Compiling my project is done using maven pluggins
> maven-dependency-plugin and features-maven-plugin.
> First unpack apache-karaf-2.2.3.zip.
> The second component uses mvn:org.apache.camel.karaf/apache-camel/${ camel-version }/xml/features
> karaf-version = 2.2.3
> camel-version = 2.9.0-SNAPSHOT (build 2011-11-10)
> Establish the following set of components
> {code}
> <feature version='${karaf-version}'>ssh</feature>
> <feature version='${karaf-version}'>config</feature>
> <feature version='${karaf-version}'>webconsole</feature>
> <feature version='${karaf-version}'>wrapper</feature>
> <feature version='${camel-version}'>camel-blueprint</feature>
> <feature version='${camel-version}'>camel-ftp</feature>
> <feature version='${camel-version}'>camel-http</feature>
> <feature version='${camel-version}'>camel-http4</feature>
> <feature version='${camel-version}'>camel-quartz</feature>
> {code}
> After starting karaf error log ${karaf.data}/log/karag.log
> {code}
> 2011-11-10 16:19:51,128 | ERROR | Thread-6                                          
                | FeaturesServiceImpl              | s.internal.Features
> ServiceImpl$1  977 | 11 - org.apache.karaf.features.core - 2.2.3 | Error installing boot
features
> java.lang.Exception: Could not start bundle mvn:org.apache.camel.karaf/camel-karaf-commands/2.9.0-SNAPSHOT
in feature(s) camel-core-2.9.0-SNAPSHOT: Unresolve
> d constraint in bundle org.apache.camel.karaf.camel-karaf-commands [95]: Unable to resolve
95.0: missing requirement [95.0] package; (&(package=org.apache.fe
> lix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
>         at org.apache.karaf.features.internal.FeaturesServiceImpl.installFeatures(FeaturesServiceImpl.java:353)[11:org.apache.karaf.features.core:2.2.3]
>         at org.apache.karaf.features.internal.FeaturesServiceImpl$1.run(FeaturesServiceImpl.java:975)[11:org.apache.karaf.features.core:2.2.3]
> Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.camel.karaf.camel-karaf-commands
[95]: Unable to resolve 95.0: miss
> ing requirement [95.0] package; (&(package=org.apache.felix.gogo.commands)(version>=0.10.0)(!(version>=1.0.0)))
> {code}
> We must add a dependency on a component in a file features.xml
> Camel 2.8.1 and 2.7.0 to work correctly.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message