camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cédric Exbrayat (Created) (JIRA) <>
Subject [jira] [Created] (CAMEL-4545) [WebConsole Archetype] Unable to run with "mvn jetty:run"
Date Fri, 14 Oct 2011 13:08:11 GMT
[WebConsole Archetype] Unable to run with "mvn jetty:run"

                 Key: CAMEL-4545
             Project: Camel
          Issue Type: Bug
          Components: tooling
    Affects Versions: 2.9.0
            Reporter: Cédric Exbrayat

If you install the camel-archetype-webconsole from the trunk (2.9-SNAPSHOT actually), and
create a new project with it ("mvn archetype:generate -DarchetypeGroupId=org.apache.camel.archetypes
-DarchetypeArtifactId=camel-archetype-webconsole -DarchetypeVersion=2.9-SNAPSHOT"), you can't
run "mvn jetty:run".
There are conflicts with slf4j-api binding as you can see in the following logs

[main] ContextLoader ERROR Context initialization failed
java.lang.NoSuchMethodError: org.slf4j.helpers.MessageFormatter.format(Ljava/lang/String;Ljava/lang/Object;)Lorg/slf4j/helpers/FormattingTuple;

Running "mvn dependencies:tree" show that two versions of slf4j are loaded.

You can find with this issue a patch that exclude slf4j for activemq-camel, which solve the

But you then ran in the following problem

... Illegal character in opaque part at index 22: jar:file:/mypath/.m2/repository/org/apache/camel/camel-web/2.9-SNAPSHOT/camel-web-2.9-SNAPSHOT.war!/WEB-INF/classes/

Which can be solved by updating jetty-version to a more recent one (7.5.3.v20111011) in the
parent pom ( issue [CAMEL-4544|] with patch)

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message