camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-4399) Upgrade to maven-bundle-plugin 2.3.5 and remove not needed special camel version for osgi manifest
Date Fri, 02 Sep 2011 05:53:10 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-4399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095787#comment-13095787
] 

Claus Ibsen commented on CAMEL-4399:
------------------------------------

There may be problems with the maven-bundle-plugin and setting version numbers in the <dynamic-import>
part of the MANIFEST.MF. I could not get that working. But I didn't spend a lot of time looking
into it.

> Upgrade to maven-bundle-plugin 2.3.5 and remove not needed special camel version for
osgi manifest
> --------------------------------------------------------------------------------------------------
>
>                 Key: CAMEL-4399
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4399
>             Project: Camel
>          Issue Type: Task
>          Components: build system
>            Reporter: Claus Ibsen
>             Fix For: Future
>
>
> gnodet says the latest maven bundle plugin can cater for maven projects with SNAPSHOT
versions, which means we ought not need any special antrun tasks to do some osgi versioning
of the project.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message