camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nils Breunese (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-4424) Missing saxon-sql 9.1.0.8 dependency for camel-saxon in Maven Central
Date Wed, 07 Sep 2011 14:56:12 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-4424?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13099001#comment-13099001
] 

Nils Breunese commented on CAMEL-4424:
--------------------------------------

Adding that repository fixes the dependency problem (I already found and locally installed
the jar myself), but I still think this is an issue.

http://maven.apache.org/guides/mini/guide-central-repository-upload.html says: "Only releases
can be uploaded to the central repository, that means files that won't change and that only
depend on other files already released and available in the repository."

https://docs.sonatype.org/display/Repository/Central+Sync+Requirements says: "In ideal conditions,
all your dependencies should be already in central and central repository is self-contained.
Otherwise people's build might break because of missing dependencies. If some of your dependencies
are not in central, please upload them using our 3rd-party artifacts bundle upload service."

> Missing saxon-sql 9.1.0.8 dependency for camel-saxon in Maven Central
> ---------------------------------------------------------------------
>
>                 Key: CAMEL-4424
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4424
>             Project: Camel
>          Issue Type: Bug
>          Components: camel-saxon
>    Affects Versions: 2.7.0, 2.8.0
>            Reporter: Nils Breunese
>
> The camel-saxon jar has a dependency on net.sf.saxon:saxon-sql:9.1.0.8. When using Maven
Central and depending on camel-saxon this doesn't work, since Maven Central does not provide
this version of this jar:
> ----
> [WARNING] The POM for net.sf.saxon:saxon-sql:jar:9.1.0.8 is missing, no dependency information
available
> ----
> Looking at http://search.maven.org/#browse%7C1332070261 I indeed only find versions 7.9.1
and 8.7.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message