camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Cheslet (JIRA)" <>
Subject [jira] [Created] (CAMEL-4444) Wrong slash in FTP component for doneFile
Date Mon, 12 Sep 2011 13:41:08 GMT
Wrong slash in FTP component for doneFile

                 Key: CAMEL-4444
             Project: Camel
          Issue Type: Bug
          Components: camel-ftp
    Affects Versions: 2.8.0
            Reporter: Olivier Cheslet

I tried to use the doneFile with FTP component.
When I used it to my FTP on my windows machine everything goes fine.
When I tried to act the same with a FTP host on a Linux machine, I got an issue.

I sniff the packet to see what goes wrong and I see this :
the doneFile 
DELE public/Test/in\myFile.txt  
the file to process
DELE public/Test/in/myFile.xml

After a Quick look on the code:
line 682

 String answer = pattern;
        if (ObjectHelper.isNotEmpty(path) && ObjectHelper.isNotEmpty(pattern)) {
            // done file must always be in same directory as the real file name
            answer = path + File.separator + pattern;

        if (getConfiguration().needToNormalize()) {
            // must normalize path to cater for Windows and other OS
            answer = FileUtil.normalizePath(answer);

We use the "File.Separator" but in this case, it should get a kind of "FTP.Separator" or the
FTP component should return true to the needToNormalize method and change the narmalizePath
method to manage this case.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message