camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: [DISCUSS] - Dropping Maven 2.x support
Date Mon, 15 Aug 2011 16:34:31 GMT
Seems a sensible approach
On 14 Aug 2011, at 10:35, Claus Ibsen wrote:

> Hi
> 
> I wonder if we should consider dropping any official support for Maven
> 2.x on the Apache Camel project?
> I guess most people is now migrated to Maven 3.0. And the last number
> of releases has been done using Maven 3.0.x.
> 
> Also in light of JDK 7 is now GA, and thus there could be issues with
> old Maven 2.x to use that to build Apache Camel.
> And the maintainers of Maven is most likely to focus on Maven 3.x to
> fix any JDK 7 issues and whatnot.
> 
> We may want to coordinate this with some of the Apache projects that
> we work closely with such as
> - Apache ServiceMix
> - Apache Karaf
> - Apache CXF
> - Apache ActiveMQ
> 
> As some people use Maven to build all the projects from the source.
> 
> 
> For example for Camel 2.9 we could put out in the release notes that
> Maven 2.x supports is being @deprecated and expected
> to be dropped in a future release. Then at least we have put out the
> word that Maven 2.x is to be dropped.
> 
> 
> Any thoughts?
> 
> 
> 
> -- 
> Claus Ibsen
> -----------------
> FuseSource
> Email: cibsen@fusesource.com
> Web: http://fusesource.com
> Twitter: davsclaus, fusenews
> Blog: http://davsclaus.blogspot.com/
> Author of Camel in Action: http://www.manning.com/ibsen/


Mime
View raw message