camel-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Willem Jiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CAMEL-4209) Upgrade camel-guice to use guice 3.0
Date Tue, 26 Jul 2011 15:37:09 GMT

    [ https://issues.apache.org/jira/browse/CAMEL-4209?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13071159#comment-13071159
] 

Willem Jiang commented on CAMEL-4209:
-------------------------------------

Hi Tim,
You are right, it more like a guicefruit issue instead of camel-guice issue.
After digging the guicefruit code a while, I found James did some change on the guice core,
so guicefruit cannot work with guice which from the central maven out of box. There may be
some work to do.

> Upgrade camel-guice to use guice 3.0
> ------------------------------------
>
>                 Key: CAMEL-4209
>                 URL: https://issues.apache.org/jira/browse/CAMEL-4209
>             Project: Camel
>          Issue Type: Improvement
>          Components: camel-guice
>            Reporter: Willem Jiang
>            Assignee: Willem Jiang
>             Fix For: 2.9.0
>
>
> As Guice 3.0 is released for a while, we should consider to upgrade the guice version
of camel-guice.
> Here is the thread[1] which discusses about it.
> [1]http://camel.465427.n5.nabble.com/camel-guice-td4565474.html

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message